Eclipse AppCompat ADT ... o que é ?

? Omar.Ebrahim @ | Original: StackOverFlow
---

Passei a tarde toda se absolutamente nada com isso. Fiz o download de Eclipse, o download do SDK, instalou as atualizações, mas a cada novo projeto Android I criar algo está errado.

Em primeiro lugar, ele não iria gerar o arquivo R.java, em tudo, agora ele faz, mas não há um projeto separado é criado automaticamente chamado appcompat_v7 . Eu não sei o que é isso, mas ele está causando problemas com qualquer outro novo projeto.

Este é o erro de um projeto normais produz : O recipiente referências ' Dependências Android ' não ' /home/omar/workspace/appcompat_v7/bin/appcompat_v7.jar ' existente biblioteca

Eu não tenho absolutamente nenhuma idéia de como consertar isso. O que está causando isso?

EDIT Ele aparece este é apenas com KitKat, cada outra plataforma API não produz quaisquer arquivos de origem em tudo .... alguma idéia de como combater isso?

Eclipse AppCompat ADT ... o que é?

Eclipse AppCompat ADT ... o que é?

Eclipse AppCompat ADT ... o que é?

---

Top 5 Responder

1NickT @

É uma biblioteca de suporte que, presumivelmente, seu projeto se refere. Você vai precisar para construí-lo como um projeto de biblioteca em seu espaço de trabalho . Este processo é descrito aqui https://developer.android.com/tools/support-library/setup.html sob Adicionando bibliotecas com recursos.

Você vai encontrar o projeto que você precisa copiar em seu SDK na pasta :

yourSDKlocation oolsandroid -sdk - windows4.4extrasandroidsupportv7appcompat

( Não adianta apenas copiando um frasco, você deve construir -lo como um projeto de biblioteca . )