Questão Android Estúdio Gradle atualização para a versão 0.5.0 - Gradle Migrando do 0,8-0,9 - Também Android Estúdio atualizar para 0.8.1

? Cedric Simon @ | Original: StackOverFlow
---

Após estados de mensagens de atualização:

Failed to refresh Gradle project 'XXX'
The project is using an unsupported version of the Android Gradle plug-in (0.8.3).
Version 0.9.0 introduced incompatible changes in the build language.
Please read the migration guide to learn how to update your project.

O mesmo tipo de problema após a atualização para o Android Studio para a versão > = 0.8.0

---

Top 5 Responder

1Cedric Simon @

Para corrigi-lo, abrir o arquivo chamado build.gradle na raiz do projeto e alterar a versão gradle lá para 0,9 . + .

buildscript {
    repositories {
        mavenCentral()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:0.9.+'
    }
}

Para ser repetido para cada projeto ; (

Se você, em seguida, receber uma mensagem como " Não é possível carregar classe ' org.gradle.api.artifacts.result.ResolvedComponentResult " .

Ir para você project_folder/gradle/wrapper diretório e editar Unable to load class 'org.gradle.api.artifacts.result.ResolvedComponentResult'. file mudando o distributionUrl para

distributionUrl=http://services.gradle.org/distributions/gradle-1.10-all.zip

Após a atualização para a versão 0.8.1 (download completo e copiar a pasta SDK over), tinha que ter nova versão do gradle instalado pelo IDE (usando o "Fix it " ligar um par de tempo : S), e modifing a seção " android " do arquivo gradle na pasta do projeto 19,0-19,1, como abaixo:     buildscript {         repositórios {             mavenCentral ( )         }         dependências {             classpath ' com.android.tools.build:gradle:0.12.+ '         }     }     aplicar plugin: ' android '

repositories {
    mavenCentral()
}

android {
    compileSdkVersion 19
    buildToolsVersion '19.1.0'

    defaultConfig {
        minSdkVersion 7
        targetSdkVersion 19
    }
}

dependencies {
    compile 'com.android.support:appcompat-v7:19.1.+'
    compile 'com.android.support:support-v4:19.1.0'
}
2Gabriele Mariotti @

Android Estúdio 0.5.0 requer gradle -plugin 0.9.0

O gradle -plugin 0.9.0 trabalha com Gradle 1.10 ou 1.11 Gradle

Modifique seu script build.gradle como sugerido por Cedric .

Existe uma relação entre gradle -plugin ea versão gradle . por exemplo

com.android.tools.build:gradle:0.6.+   -> gradle 1.8
com.android.tools.build:gradle:0.7.+   -> gradle 1.9
com.android.tools.build:gradle:0.8.+   -> gradle 1.9/1.10
com.android.tools.build:gradle:0.9.+   -> gradle 1.10/1.11
com.android.tools.build:gradle:0.10.+  -> gradle 1.10/1.11/1.12
com.android.tools.build:gradle:0.11.+  -> gradle 1.10/1.11/1.12
com.android.tools.build:gradle:0.12.+  -> gradle 1.10/1.11/1.12
com.android.tools.build:gradle:0.13.+  -> gradle 2.1
com.android.tools.build:gradle:0.14.+  -> gradle 2.1
com.android.tools.build:gradle:1.0.+   -> gradle 2.2.1

Você pode encontrar a versão gradle usado em seu projeto no arquivo gradle/wrapper/gradle-wrapper.properties

Também há uma relação entre gradle -plugin ea versão IDE. ATUALIZADO PARA 2014/08/12 :

Android Studio 0.3.x  -> gradle-plugin 0.6
Android Studio 0.4.x  -> gradle-plugin 0.7
Android Studio 0.4.3+ -> gradle-plugin 0.8
Android Studio 0.5.x  -> gradle-plugin 0.9
Android Studio 0.5.8  -> gradle-plugin 0.9.+ or 0.10.+
Android Studio 0.5.9  -> gradle-plugin 0.9.+ or 0.10.4+
Android Studio 0.6.x  -> gradle-plugin 0.11.+
Android Studio 0.8.x  -> gradle-plugin 0.12.+
Android Studio 0.8.11+  -> gradle-plugin 0.13.+ / gradle-plugin 0.12.+
Android Studio 0.9.x  -> gradle-plugin 0.14.+
Android Studio 1.0.0  -> gradle-plugin 1.0.0

 Also gradle 1.12 requires Android Studio 0.5.8+

Para notícias atualizadas você pode conferir neste link: http://tools.android.com/recent

Se você mudar sua versão plug-in, verifique a compatibilidade e, em seguida, clique projeto sincronia com o seu files.It gradle irá baixar uma nova versão do plugin se você precisar dele .

3pierre renoir @

hmm Estou recebendo este erro quando eu tento adicionar essa dependência .

Erro: (22) Um problema avaliar projeto ': app' .

Não foi possível encontrar o método classpath () para argumentos [ com.android.tools.build:gradle:0.9.+ ] no projeto ': app' .

Ok resolveu. Esta linha deve ser parte da build.gradle " na raiz do projeto ", como dito acima, mas eu não reconheci. Atualizando as ferramentas de compilação para 19,03 realmente inserido automaticamente.

4lucidbrot @

Eu tive o mesmo erro, mas já teve

classpath 'com.android.tools.build:gradle:0.9.+'

definir como este, como Cedric Simon sugeriu . Graças ao comentário de mattblang, tentei alterá-lo para 0.9.0 e revigorado -lo

para quem não sabe, onde o botão de atualização é, olhe abaixo :

Questão Android Estúdio Gradle atualização para a versão 0.5.0 - Gradle Migrando do 0,8-0,9 - Também Android Estúdio atualizar para 0.8.1

Depois eu tentei o que acontece quando eu mudá-lo de volta para 0,9 . + E atualizar novamente ... e ele ainda funciona .

Então, eu assumo, apenas pressionando o botão de atualização seria suficiente.

5codercat @

O projeto mais simples Android tem a seguinte build.gradle :

buildscript {
    repositories {
        mavenCentral()
    }

    dependencies {
        classpath 'com.android.tools.build:gradle:0.9.0'
    }
}

apply plugin: 'android'

android {
    compileSdkVersion 19
    buildToolsVersion "19.0.0"
}

Existem 3 áreas principais para este arquivo de construção Android:

http://tools.android.com/tech-docs/new-build-system/user-guide