Eclipse ADT : Nome do projeto " appcompat_v7 " que está sendo criado após a criação de cada novo projeto

? uLYsseus @ | Original: StackOverFlow
---

Bem, eu quero destacar isso e trazer tudo neste segmento, como o resto de threads não tinha uma resposta concluiu, por isso antes de saltar para eles aqui são os tópicos que me referi :

http://stackoverflow.com/questions/22203862/adt-doesnt-create-default-hello-world-but-command-line-does

http://stackoverflow.com/questions/22250633/eclipse-behaving-differently-while-creating-new-project-activity

ADT tem se comportado um pouco estranho, já que nos últimos dias. Eu mantenho meu SDK sempre atualizado para que eu freqüentemente Execute o gerente SDK e baixar todas as atualizações. Recentemente notei que se eu criar um novo projeto app android não está criando um MainActivity padrão, mesmo se eu verificar que a caixa, ele não cria uma atividade sob src e mais para me irritar, eu não era capaz de refazer nada, então eu percebi que eu tinha que atualizar meu Eclipse como depois de ler alguns posts, mas agora quando eu crio a cada novo projeto cria um projeto appcompat_v7 chato com cada projeto, dizer que eu criar dois novos projetos que ele cria appcompat_v7_2 .... isso está me deixando louco e a nova biblioteca do projeto é o projeto appcompat_v7 . Isso está se tornando chato e não tem idéia o que está acontecendo aqui !!!! O que devo fazer ... por favor me salve ! Agradecemos antecipadamente .... Uma captura de tela para irritar u caras também ... :)

Eclipse ADT : Nome do projeto " appcompat_v7 " que está sendo criado após a criação de cada novo projeto

*************** Alternativa atual, não uma solução ***********************

A partir de 2014/12/05 com ADT 23.0.2 Eu não vejo esse problema mais.

I have waited for an acceptable solution on this issue (as of now there is none), but one of the SO members directed me to this post https://code.google.com/p/android/issues/detail?id=66975 . What I am doing is described in one of the solutions below, but for people who have come to this post, the alternative is to delete that ugly project(if you have more than one) which has been created and add up this one(appcompat_v7) as a library. So if you create another project and appcomat_v7_2...comes up delete that and point your project to the appcompat_v7, do the same for other projects too. This is not recommended for some reason though, but it worked well for me till now without issues. If anyone hits up with a solution please post it here. **************** Alternativa atual, não uma solução *****************************

---

Top 5 Responder

1user3033613 @

o appcompat_v7 doesnt pasta ser criada se eu usar

minSdkVersion="14"
2shap4th @

Parece que é um bug eclipse. O que você precisa fazer é ir para propriedades na do Projeto Android e na seção de Android . Adicione o appcompat_v7 biblioteca e remover o appcompat_v_7_2 ( duplicado) . Em seguida, você pode remover o appcompat_v7_2 como um projeto eclipse. Todos os erros corrigidos.

Apenas uma solução alternativa.

3GPrimola @

O projeto AppCompat é uma biblioteca para apoiar as versões mais antigas do Android. A biblioteca de apoio foi introduzida pelo Google recentemente - eu não sei em qual versão do Android. Mas o ponto é, este projeto só é criado quando você cria um projeto Android para atravessar plataformas Android. Quero dizer, quando você seleciona um velho min API, por exemplo API 8 (Froyo ), mas alvo recentemente versões, seu projeto deve ter a biblioteca de suporte . De qualquer forma, a criação de appcompat_v7 projeto é uma questão que tem de ser melhor configurado pelos mantenedores eclipse plugin. No entanto, você pode elegantemente virar esse problema, visando APIs mais recentes e incluindo no caminho de construção da biblioteca de suporte . Este é mais elegante do que os outros, porque é melhor para você se concentrar em apenas uma versão android ao construir sua candidatura, e quando ele é feito, você tem uma versão autêntica do seu aplicativo que você pode usar como um molde para apoiar outras versões, ou mais velhas ou newers .