Corrigindo erros no styles.xml para gerar R.java : No recurso encontrado nome ' Theme.AppCompat.Light '

? ravensgo @ | Original: StackOverFlow
---

Eu sou novo para Android e estou tentando executar o meu primeiro programa. No entanto, com base em minhas pesquisas em toda a internet, eu acho que eu não posso importar mypackage.R, porque r.java não foi gerado por causa de erros em meus arquivos style.xml . Tenho procurado por aí tentando descobrir como corrigir estes, mas eu não consigo encontrar uma solução que funciona. O erro styles.xml representa

error: Error retrieving parent for item: No resource found that matches the given name 'Theme.AppCompat.Light'

Alguém sabe como consertar isso ?

! [ Erros em style.txt ] [1 ]

Aqui está o código que estou usando:

package com.example.test;

import android.os.Bundle;
import android.app.Activity;
import android.view.Menu;
import android.view.MenuItem;

public class MainActivity extends Activity {

@Override
public void onCreate(Bundle savedInstanceState) {
    super.onCreate(savedInstanceState);
    setContentView(R.layout.activity_main);
}
@Override
public boolean onCreateOptionsMenu(Menu menu) {
    getMenuInflater().inflate(R.menu.activity_main, menu);
    return true;
}
}

UPDATE: Aqui está styles.xml :

<resources>

<!--
    Base application theme, dependent on API level. This theme is replaced
    by AppBaseTheme from res/values-vXX/styles.xml on newer devices.
-->
<style name="AppBaseTheme" parent="Theme.AppCompat.Light">
    <!--
        Theme customizations available in newer API levels can go in
        res/values-vXX/styles.xml, while customizations related to
        backward-compatibility can go here.
    -->
</style>

<!-- Application theme. -->
<style name="AppTheme" parent="AppBaseTheme">
    <!-- All customizations that are NOT specific to a particular API-level can go here. -->
</style>

</resources>

UPDATE 2 : Aqui está AndroidManifest.xml

<?xml version="1.0" encoding="utf-8"?>
<manifest xmlns:android="http://schemas.android.com/apk/res/android"
package="com.example.test"
android:versionCode="1"
android:versionName="1.0" >

<uses-sdk
    android:minSdkVersion="8"
    android:targetSdkVersion="19" />

<application
    android:allowBackup="true"
    android:icon="@drawable/ic_launcher"
    android:label="@string/app_name"
    android:theme="@style/AppTheme" >
    <activity
        android:name="com.example.test.MainActivity"
        android:label="@string/app_name" >
        <intent-filter>
            <action android:name="android.intent.action.MAIN" />

            <category android:name="android.intent.category.LAUNCHER" />
        </intent-filter>
    </activity>
</application>

</manifest>
---

Top 5 Responder

1Ye Lin Aung @

Desde que você está usando Theme.AppCompat.Light em seu tema, você tem que incluir appCompat em seu projeto.

Arquivo-> Import ( android- sdkextrasandroidsupportv7 ) . Escolha " AppCompat "

Projeto-> propriedades- > Android . Na biblioteca de secção

"Adicionar" e escolha " AppCompat "

Isso deve funcionar .

2Hamid Shatu @

Você está tentando usar Theme.AppCompat.Light é o tema que é um projeto de biblioteca . Você tem que fazer referência a esse projeto de biblioteca para o seu projeto.

Agora, em primeiro lugar, verifique se você tiver instalado este projeto de biblioteca da seguinte forma ...

Vá Janela -> Android SDK Gerente então uma janela chamada Android SDK Manager irá aparecer como abaixo.

Corrigindo erros no styles.xml para gerar R.java : No recurso encontrado nome ' Theme.AppCompat.Light '

Se o Android Support Library não está instalado, em seguida, instalá-lo. Você pode ver mais informações sobre Android Support Library setup do local abaixo Android Developer.

https://developer.android.com/tools/support-library/setup.html

Depois de Android Support Library conclusão da instalação, faz referência a biblioteca para o seu projeto a partir deste caminho ...

android-sdk/extras/android/support/v7/appcompat

Para referência, siga estes passos:

File->Import (android-sdkextrasandroidsupportv7). Choose "appcompat" Projeto-> propriedades- > Android . Na biblioteca de secção "Adicionar" e escolha " AppCompat "

Agora, limpar e construir o projeto e executá-lo. Acho que depois de tudo isso, o problema será resolvido.

3donfuxx @

Certifique-se de que você fechou o <resources> tag corretamente e adicionar na parte inferior do seu styles.xml :

 </resources>

de acordo com seu trecho de código Publicado que não está presente, mas precisa ser

Edit: a tag recursos faltantes foi apenas um erro de copiar e colar em questão, de modo que aqui não era a razão .

4SKM @

Eu finalmente descobri o problema. Eu tive que excluir esta linha de código do meu main.xml :

android:showAsAction="never"

Sob meus values-v11 e pastas values-14 Eu mudei o nome do app para ...

style name="AppBaseTheme" parent="android:Theme.Light"

... e ele está trabalhando atualmente .