Eclipse não gerar MainActivity.java & activity_main.xml

? Vivek Warde @ | Original: StackOverFlow
---

Sobre a criação de um novo projeto de aplicativo Android, MainActivity.java sob o nome do pacote deve ser gerado automaticamente em pasta src & amp; activity_main.xml Deve ser criado dentro da pasta layout. Mas não é criado.

Eclipse não gerar MainActivity.java & activity_main.xml

E também no manifesto ele doesn `t gerar este POC

 <activity
        android:name="info.androidhive.slidingmenu.MainActivity"
        android:label="@string/app_name" >
        <intent-filter>
            <action android:name="android.intent.action.MAIN" />

            <category android:name="android.intent.category.LAUNCHER" />
        </intent-filter>
    </activity>

No entanto, eu adicionei todas essas coisas manualmente.

activity_main.xml seguida, mostra este erro

 Eclipse is loading framework information and the layout library from the SDK folder.
 activity_main.xml will refresh automatically once the process is finished.

Não MainActivity.java não reconhecer o campo de layout em setContentView(R.layout.activity_main)

E ontem eu downloalded as atualizações a partir do Gestor SDK essas ferramentas estão instalados / atualizados Eclipse não gerar MainActivity.java & activity_main.xml  Eclipse não gerar MainActivity.java & activity_main.xml

Eu tentei limpar o projeto, mudando o espaço de trabalho, reiniciar o eclipse & amp; O Windows, mas não ajuda :(

---

Top 5 Responder

1Little Child @

Há uma opção para selecionar se deseja gerar MainActivity e activity_main.xml . Tem certeza de que você selecionou aqueles ? Certifique-se selecionar isso.

Eclipse não gerar MainActivity.java & activity_main.xml

Sem isso, o meu projeto é a mesma de seu:

Eclipse não gerar MainActivity.java & activity_main.xml

2TGMCians @

As one guy said

Eu tive o mesmo problema, embora eu baixei o SDK Android e fiz uma instalação limpa, mas eu só resolvido isso. Tentei clique em "Ajuda " -> "Verificar atualizações ", e então eu recebi uma mensagem pop -up dizendo que tudo foi até à data, mas depois de pesquisar mais pareceu-me que não era até à data. O que você precisa fazer é clicar em "Ajuda" -> " Instalar um novo software " e instalar (isso irá atualizá-lo ) a partir desta url: https://dl-ssl.google.com/android/eclipse/

Veja aqui enfiar https://code.google.com/p/android/issues/detail?id=66647

3Solution @

Essas soluções não funcionou para mim também, mas o que resolve o problema para mim foi a exclusão do AppCompat projetos que são auto- criado quando criamos um novo projeto de aplicação android .

4user3562859 @

A mesma coisa aconteceu comigo dois dias atrás, depois de atualizar SDK através android Gerente SDK. Quando eu reiniciei eclipse, eu tenho um pop -up dizendo que minha ferramenta Android Development (ADT) ou um plugin para o Eclipse precisa de atualização para a versão 22.6.2

Aqui está a informação http://developer.android.com/tools/sdk/eclipse-adt.html

e clique em atualizar ADT, as instruções de download estão lá .

Copiei isso aqui apenas no caso,

Baixe o ADT Plugin Iniciar Eclipse, selecione Ajuda > Instalar Novo Software. Clique em Adicionar, no canto superior direito. Na caixa de diálogo Adicionar Repositório que aparecer, digite " ADT Plugin " para o nome e o seguinte URL para o Localização:  https://dl-ssl.google.com/android/eclipse/ Nota: O site de atualização do Android Developer Tools requer uma conexão segura . Verifique se o URL do site de atualização que você entra começa com HTTPS. Clique em OK . Na caixa de diálogo Software disponíveis, selecione a caixa de seleção ao lado de Ferramentas de Desenvolvimento e clique em Avançar . Na janela seguinte, você verá uma lista das ferramentas para ser baixado . Clique em Avançar. Leia e aceite os contratos de licença, clique em Concluir. Se você receber um aviso de segurança dizendo que a autenticidade ou a validade do software não pode ser estabelecida, clique em OK. Quando a instalação estiver concluída, reinicie o Eclipse.

Espero que isso ajude .

5doohsam @

Eu estava tendo o mesmo problema. Eu tentei criar o projeto com um SDK alvo diferente. Eu usei API 16 Android 4.1 e que trabalhou .