Jar incompatibilidade ! Corrija suas dependências ao usar appcompat_v7 e Facebook SDK.

? KousiK @ | Original: StackOverFlow
---

Eu estou usando appcompat_v7 biblioteca e facebook SDK no meu projeto e tanto a biblioteca tem android -support- v4.jar.If eu excluir qualquer um dos jar a biblioteca correspondente não está funcionando e em que tanto frascos não é permitido.

O que devo fazer? Por favor, me ajudem ...

---

Top 5 Responder

1Raghunandan @

O conflito é devido a diferentes versões do frasco.

Certifique-se de que você tem a biblioteca de suporte para a atualização do gerente Android SDK

Copy android-support-v4.jar para libs de ambos os projetos. O frasco pode ser encontrado @

android-sdk/extras/android/support/v4/andorid-support-v4.jar

Limpe e construir seu projeto

2milapTank @

remover android -support- v4.jar do FACEBOOK SDK e adicionar android -support- v4.jar como propriedades facebookSDK JAR externo -> Caminho de Construção Java - > bibliotecas -> adicionar jar externo (i teve remover esse problema como este )

3user2678995 @

Tente remover a biblioteca dependência de ambos appcompat_v7 e seu projeto. Para isso tem que construir path = > caminho configure compilação. Em seguida, selecione a biblioteca de dependência e clique em Remover . Adicione a biblioteca de suporte por Android Tools => adicionar biblioteca de suporte . Faça isso para ambos projects.Then você é bom para ir

4Safdar Akrami @

Sua realmente simples

Basta clicar sobre o seu projecto, bem como sobre o projeto de biblioteca > Android Tools > Adicionar biblioteca de apoio.

Isto irá atualizar a sua biblioteca de suporte para a mais recente que resolve o problema .

5Rahul Mandaliya @

Esta questão é perguntar muitas vezes enquanto todos são start- up de desenvolvimento do Android em fase de aprendizagem . Acho que todo mundo tem o mesmo ambiente de android mas eles configurar de forma diferente de acordo com a projectos .

Eu tinha mesmo problema ao criar novo projeto de cada vez e eu achei solução no abaixo. Eu adicionei appcompat_v7 biblioteca em projeto e remover jar android-support-v4.jar da pasta lib do meu novo projeto e piscar ERROR tinha ido embora. Adicionar appcompt_v7 projeto de biblioteca  Jar incompatibilidade ! Corrija suas dependências ao usar appcompat_v7 e Facebook SDK.

Remover android -support- v4.jar da pasta lib do projeto  Jar incompatibilidade ! Corrija suas dependências ao usar appcompat_v7 e Facebook SDK.

Wow erro se foi  Jar incompatibilidade ! Corrija suas dependências ao usar appcompat_v7 e Facebook SDK.