Como resolver o erro Android estúdio onde ele não pode encontrar o arquivo de manifesto do projeto ?

? Fergers @ | Original: StackOverFlow
---

Eu estou migrando meu projeto legado de Eclipse para estúdio Android . Eu fiz as seguintes coisas :

Export and generate gradle build files in eclipse Imported the Gradle.build file in Android Studio Changed my gradle version dependencies to: classpath 'com.android.tools.build:gradle:0.9.+'

Minha pasta raiz do projeto contém três projetos de biblioteca : Actionbarsherlock, Authbahn e biblioteca. Minha pasta raiz também contém o projeto principal, chamado JohelpenHulpverlener .

Como resolver o erro Android estúdio onde ele não pode encontrar o arquivo de manifesto do projeto?

Depois de resolver um monte de erros que recebo o seguinte erro:

Error:A problem was found with the configuration of task ':checkDebugManifest'.
> File 'C:androidjeugdformaatJohelpenHulpverlenerAndroidManifest.xml' specified for property 'manifest' does not exist.

Meu build.gradle raiz parecida com esta:

// Top-level build file where you can add configuration options common to all sub-projects/modules.
buildscript {
    repositories {
        mavenCentral()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:0.9.+'
    }
}

apply plugin: 'android'

dependencies {
    compile files('libs/android-support-v4.jar')
    compile project(":actionbarsherlock")
}

android {
    compileSdkVersion 17
    buildToolsVersion "19.0.3"

    defaultConfig {
        minSdkVersion 10
        targetSdkVersion 19
    }

    sourceSets {
        main {
            manifest.srcFile 'AndroidManifest.xml'
            java.srcDirs = ['src']
            resources.srcDirs = ['src']
            res.srcDirs = ['res']
        }
    }
}

Meu build.gradle no projeto principal se parece com isso :

apply plugin: 'android'

dependencies {
    compile fileTree(dir: 'libs', include: '*.jar')
    compile project(':library')
    compile project(':actionbarsherlock')
    compile project(':autobahn')
}

android {
    compileSdkVersion 19
    buildToolsVersion "19.0.0"

    sourceSets {
        main {
            manifest.srcFile 'AndroidManifest.xml'
            java.srcDirs = ['src']
            resources.srcDirs = ['src']
            aidl.srcDirs = ['src']
            renderscript.srcDirs = ['src']
            res.srcDirs = ['res']
            assets.srcDirs = ['assets']
        }

        // Move the tests to tests/java, tests/res, etc...
        instrumentTest.setRoot('tests')

        // Move the build types to build-types/<type>
        // For instance, build-types/debug/java, build-types/debug/AndroidManifest.xml, ...
        // This moves them out of them default location under src/<type>/... which would
        // conflict with src/ being used by the main source set.
        // Adding new build types or product flavors should be accompanied
        // by a similar customization.
        debug.setRoot('build-types/debug')
        release.setRoot('build-types/release')
    }
}

Eu estou tentando entender isso, espero que alguém pode me ajudar aqui !

---

Top 5 Responder

1ElectronicGeek @

Certifique-se de ter marcas no exterior como este:

<?xml version="1.0" encoding="utf-8"?>
<manifest xmlns:android="http://schemas.android.com/apk/res/android"
    package="com.example"
    android:versionCode="1"
    android:versionName="1.0" >

    ...

</manifest>
2Scott Barta @

Você tem um monte de coisas em sua raiz-nível Gradle construir arquivo que está fazendo o sistema de construção acho que há um módulo Android lá (não é, é um subdiretório abaixo dentro JohelpenHulpverlener ), e ele está falhando porque não está encontrando o manifesto.

Eu acho que se você tomar um monte de coisas fora de seu arquivo build.gradle de nível de raiz e substituí-lo com a versão padrão para novos projetos, que é a seguinte:

// Top-level build file where you can add configuration options common to all sub-projects/modules.
buildscript {
    repositories {
        mavenCentral()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:0.9.+'
    }
}

allprojects {
    repositories {
        mavenCentral()
    }
}

it will work.

3Umesh @

Em arquivo build.gradle especificar o nome do pacote como

android {
compileSdkVersion 19
buildToolsVersion "20.0.0"


defaultConfig {
    applicationId "com.myapp"
    minSdkVersion 11
    targetSdkVersion 19
    versionCode 27
    versionName "1.5.6"
}
}

applicationId "com.myapp" Here " com.myapp " é nome do pacote do meu aplicativo . Espero que isso irá ajudá-lo .