Mensagem de erro: Este SDK Android requer Android Developer Toolkit versão 22.6.1 ou superior

? kuba @ | Original: StackOverFlow
---

Recentemente eu encontrei seguinte erro:

Mensagem de erro: Este SDK Android requer Android Developer Toolkit versão 22.6.1 ou superior

A coisa mais estranha é que eu só atualizou algum pacote de SDK via eclipse trabalhando . Não havia nenhuma informação ou aviso de que após essa atualização adt atual irá falhar. Eu verifiquei as atualizações mais recentes e não consegue encontrar novo adt mesmo na página do google . Mesmo novos adb conter adt de idade.

De http://developer.android.com/tools/sdk/tools-notes.html :

Dependências : SDK Android plataforma de ferramentas de revisão de 18 ou mais tarde . Se você   estão desenvolvendo em Eclipse com ADT, note que esta versão do SDK   Tools é projetado para uso com o ADT 22.6.1 ou posterior. Se você não tem   já, atualize seu ADT Plugin para 22.6.1 .

A única solução é baixar novo eclipse autônomo e do plugin externo para ele? O estúdio android enfrentam os mesmos problemas ?

Ambiente : linux x64.

---

Top 5 Responder

1beworker @

Eu relatei https://code.google.com/p/android/issues/detail?id=67325 ontem. A solução é usar a Ajuda -> Instalar nova opção de software com protocolo https: // (s é importante) . Não há downloads especiais ou reinstalações é necessário, basta escolher o site de atualização direita.

2Robi Kumar Tomar @

Hoje eu e um dos meus amigos enfrentou o mesmo problema, então eu tentei muitas coisas como reiniciar eclipse, verificar atualizações, etc., mas nenhum foi trabalhar para mim.

Então eu encontrei uma solução de http://developer.android.com/sdk/installing/installing-adt.html e está funcionando como um encanto para mim e também para meu amigo.

Siga os passos aqui:

Start Eclipse, then select Help > Install New Software. Click Add, in the top-right corner.

Na caixa de diálogo Add Repository que aparecer, digite " ADT Plugin " para o Nome e a seguinte URL para a Localização:

https://dl-ssl.google.com/android/eclipse/

Click OK.

Se tiver dificuldade em adquirir o plugin, tente usar "http " na localidade URL, em vez de "https" (https é preferido por razões de segurança ) .

In the Available Software dialog, select the checkbox next to Developer Tools and click Next. In the next window, you'll see a list of the tools to be downloaded. Click Next. Read and accept the license agreements, then click Finish. If you get a security warning saying that the authenticity or validity of the software can't be established, click OK. When the installation completes, restart Eclipse. 3TGMCians @

Para resolver este problema, os passos aqui eu cobri, certamente ele vai ajudá-lo.

Please follow these steps:

Ajuda | Instale o novo software

Selecione o site de atualização ADT (existem dois, um com http: // e um com https: // Se não funcionar, tente o outro.

Selecione a seção de ferramentas de desenvolvimento e pressione próximo .

Você deverá ver uma caixa de diálogo que diz " este software já está instalado, uma atualização será realizada em seu lugar" . Ao clicar ok vai levar a 22.6.1 sendo instalado.

Update 27/03/2014

http://developer.android.com/tools/sdk/eclipse-adt.html#notes

Você pode ver este tópico: https://code.google.com/p/android/issues/detail?id=67325

4babelsistemas @

O problema é que o site de atualização padrão no Android ADT é

http://dl-ssl.google.com/android/eclipse/

mas este site não atualizar corretamente

E a solução é adicionar um novo site Instale com o protocolo https

https://dl-ssl.google.com/android/eclipse/

Clique em Ajuda-> Instale New Software-> Adicionar

E usar este site para atualizar ADT

Edição: https://code.google.com/p/android/issues/detail?id=67325