Erro: Este SDK Android requer Android Developer Toolkit versão 22.6.1 ou superior

? TheLittleNaruto @ | Original: StackOverFlow
---

Eu já instalei a versão 22.6.1 ADT 2 dias atrás. Ele estava trabalhando muito bem . De repente, quando eu abrir eclipse de hoje, ele continua me mostrando seguinte erro:

Este SDK Android requer Android Developer Toolkit versão 22.6.1 ou superior. A versão atual é 22.2.1.v201309180102-833290 . Por favor, atualize ADT para a versão mais recente .

Aqui está screenshot do Gerenciador SDK Android do meu eclipse :  Erro: Este SDK Android requer Android Developer Toolkit versão 22.6.1 ou superior

Eu tentei com os seguintes passos para resolver o meu problema como discutido neste https://code.google.com/p/android/issues/detail?id=67325

Help | Install new software Select the ADT update site (there are two, one with http:// and one with https://. If one doesn't work, try the other. Select the developer tools section and press next. You should see a dialog that says This software is already installed, an update will be performed instead. Clicking OK will lead to 22.6.1 being installed.

Mas, infelizmente, não funcionou para mim.

Aqui está uma imagem que eu estou anexando o que mostra o erro que eu estou recebendo ao atualizar as ferramentas.

Erro: Este SDK Android requer Android Developer Toolkit versão 22.6.1 ou superior

Como posso me livrar dele?

---

Top 5 Responder

1X-ELECTRON @

Basta apagar o ADT existente e instalar nova versão do ADT.generally este problemas ocorre      quando você atualiza SDK usando o link abaixo .

https://dl-ssl.google.com/android/eclipse/
2Lalit @

Eu resolvi esse problema ontem.

Siga os passos: Ajuda -> Instalar Novo Software - > Adicionar -> ( Dê qualquer nome supor NewUpdate ) - > adicionar este url: https://dl-ssl.google.com/eclipse/plugin/4.2 -> OK

Agora ele irá listar as atualizações disponíveis, o que deve ser idealmente 20.xx adt

Selecione os itens da lista Que seja instalado. Eclipse será reiniciado e seu feito .

Espero que esta vontade útil para você :)

3blue @

O Bundle ADT em developer.android.com parece-me como fora de moda .

Fixei o mesmo problema por http://eclipse.org/downloads/ (Java EE foi a minha escolha, mas você pode escolher o seu sabor) e http://developer.android.com/sdk/installing/installing-adt.html

4Rick Falck @

Eu tenho atualmente Eclipse e ADT instalado no mesmo diretório

F:eclipse
    eclipse
    sdk

Eu fiz o download e instalado a última ADT para

C:UsersRickAppDataLocalAndroidandroid-sdk

Eu, então, copiado o conteúdo do C:UsersRickAppDataLocalAndroidandroid-sdk para a pasta F:eclipsesdk, e deixá-lo juntar todas as pastas e substituir tudo.

Agora eu tenho 22.6.1 e eu não tenho que baixar novamente todo o material plataforma novamente.

5Faruk Toptas @

Eu uso OSX e enfrentando o problema para 2 dias . Eu resolvi o problema seguindo os passos abaixo:

-Transferir ADT Bundle de https://developer.android.com/sdk/index.html -Ajuda - > Instalar Novo Software -Write Https://dl-ssl.google.com/android/eclipse/ em seguida, instalar ferramentas de desenvolvedor -Restart Eclipse e levantou o erro abaixo :

Android SDK content Loader has encountered a problem.parseSdkContent failed
java.lang.NullPointeException

Pasta .android -delete no perfil do usuário . Restart eclipse

Sem erros e 22.6.1 está instalado.