Como posso criar um novo projeto sem appcompat_v7

? Ankit Kumar @ | Original: StackOverFlow
---

Eu sou incapaz de obter porque appcompat_v7 é criado automaticamente ... achando muito irritante .. por favor alguém ajude a se livrar deste problema. Tentei criar novo projeto e encontrou como este para cada projeto recém-criado.

---

Top 5 Responder

1taxo @

Ao criar um novo projeto Android remover a seleção na frente de "Criar atividade " . Ao fazer isso, Eclipse não irá importar automaticamente o projeto de biblioteca " appcompat_v7 " . Então você tem manualmente para criar a atividade principal. Cuidado com o que importa você usar se você tem coisas como Fragment ou ActionBar .

http://stackoverflow.com/questions/22261288/why-eclipse-automatically-adds-appcompat-v7-library-support-whenever-i-create-a é muito útil .

Espero que isso ajude ! :)

2Ishara Amarasekera @

Quando você cria seu aplicativo, dar API 14: Android 4.0 ou uma versão superior, como a versão mínima SDK.

3svg @

a razão pela qual Eclipse faz isso é porque há uma grande quantidade de fragmentação em diferentes fornecedores e versões do Android e o mesmo reflete na API é muito .. !! Portanto, a fim manter tudo vai suave Android sugere a adição de bibliotecas externas para o projeto Eclipse e permanece com o mesmo .

Você pode se livrar dele se você construiu, alvo e compilar nível mesmo, usando SDK mínimo acima 7 devem também fazer o truque.

referir  http://stackoverflow.com/questions/22261288/why-eclipse-automatically-adds-appcompat-v7-library-support-whenever-i-create-a