Sem versão em cache com.android.tools.build:gradle:0.9.1 disponível para o modo off-line

? robin @ | Original: StackOverFlow
---

Recebi uma mensagem de um erro durante a construção de um novo projeto Olá Mundo em Android Studio.

FALHA : Constituição falhou com uma exceção.

O que deu errado : Ocorreu um problema configurando projeto raiz MyApplication2 .

Could not resolve all dependencies for configuration ':classpath'.
Could not resolve com.android.tools.build:gradle:0.9.1.
Required by:
    :MyApplication2:unspecified
No cached version of com.android.tools.build:gradle:0.9.1 available for offline mode.

BUILD FAILED

Android versão Estúdio: 0.5.2 Gradle versão : 0.9.1

Eu estou usando uma conexão proxy para Internet.

Por favor, alguém pode dar uma solução para este problema. Tenho pesquisado internet para problema acima, mas não conseguiu obter qualquer solução adequada para este problema .

---

Top 5 Responder

1friedrich @

Teve o mesmo erro após a atualização Android Estúdio hoje. Para mim, não era uma questão de configurações de proxy :

Uncheck "Offline work" in File>Settings>Gradle>Global Gradle Settings Resync the project, for example by restarting the Android Studio Once synced, you can check the option again to work offline.

( Gradle versão 0.11 ... e Android Studio versão 0.6.0 Preview)

2Tony D @

Desde que você mencionar que você tem uma conexão proxy eu vou lhe dizer o que funcionou para mim: Eu fui para propriedades (como Friedrich mencionado ) garantir a Work Offline foi desmarcada. Eu abri o arquivo gradle.properties no IDE e acrescentou minhas configurações de proxy. Aqui está uma versão genérica:

systemProp.http.proxyHost=www.somehost.org
systemProp.http.proxyPort=8080
systemProp.http.proxyUser=userid
systemProp.http.proxyPassword=password
systemProp.http.nonProxyHosts=*.nonproxyrepos.com|localhost

Em seguida, na parte superior do arquivo de propriedades no IDE havia um link " Try Again ", que eu cliquei . Que fez isso .