Corrigir Gradle problema de incompatibilidade ao importar projeto de exemplo Android

? Sebastien @ | Original: StackOverFlow
---

Estúdio Android ( 0.5.3 ) está me deixando louco .

Eu nunca tive problemas sérios com Eclipse e ADT. Android Studio é outra história : eu não tenho sido capaz de obter um único projeto para construir corretamente com ele.

Então, eu estou tentando importar um projeto de exemplo Android ( que suponho que tem configurações gradle corretas e devem prontos para serem importados ):

C:pathToMyAndroidSDKsdksamplesandroid-19contentStorageProvider

O primeiro erro que eu vejo é o seguinte :

Failed to refresh Gradle project 'StorageProvider'
The project is using an unsupported version of Gradle. Please use version 1.10.
Please point to a supported Gradle version in the project's Gradle settings or in the project's Gradle wrapper (if applicable.)
Fix Gradle wrapper and re-import project Gradle settings

OK, então eu baixar Gradle 1,10, e alterar as configurações gradle projeto, para que ele use essa distribuição Gradle local em vez de o wrapper gradle default (o que parece ser incluído no projeto de exemplo ) .

Recebo um erro diferente desta vez :

Failed to refresh Gradle project 'StorageProvider'
The project is using an unsupported version of the Android Gradle plug-in (0.8.3).
Version 0.9.0 introduced incompatible changes in the build language.
Please read the migration guide to learn how to update your project.

Eu não sei Gradle suficiente para migrar a configuração mim mesmo, e eu realmente não quero .

Como posso simplesmente usar o wrapper gradle sem gettting convocado para usar Gradle 1,10 ( o que não é compatível com o projeto) ? Qualquer outra solução também é bem-vinda .

Nota: Eu tentei com outros projetos de exemplo na pasta android -19, apenas para obter os mesmos erros.

EDIT:

Eu tive mais sorte tentando construir no Linux com a linha de comando ( gradlew build ) .

A compilação bem-sucedida, independentemente do que eu definido em build.gradle :

classpath 'com.android.tools.build:gradle:0.9.+'

or

classpath 'com.android.tools.build:gradle:0.8.+' #(the original configuration of the sample project)

Então, meu problema parece ser causado por erros no Android Studio.

---

Top 5 Responder

1Gabriele Mariotti @

Sem saber gradle, é bastante difícil de resolver este problema .

Ao mesmo tempo Android Studio é uma versão alfa, por isso pode mudar rapidamente, e cada versão pode introduzir mudanças incompatíveis

Aqui o primeiro doc para ler sobre um projeto com Android Estúdio:  https://developer.android.com/sdk/installing/studio-build.html

Você está usando AS 0.5.3 assim que você tem que usar gradle 1.10 / 1.11 eo 0.9.x do plugin gradle

Isso significa que no seu script build.gradle você tem que usar :

buildscript {
    repositories {
        mavenCentral()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:0.9.+'
    }
}

Pode ser no seu arquivo você tem 0.8.3 .

Além disso, você tem que usar gradle 1.10 / 1.11 . Você deve ter uma pasta * project_folder / gradle / invólucro * onde existe um arquivo gradle-wrapper.properties .

Aqui você tem que mudar a chave distributionUrl para usar um desses versão :

distributionUrl = http : //services.gradle.org/distributions/gradle-1.10-all.zip

Android Studio - Gradle - Gradle plugin de ter alguma relação :

http://stackoverflow.com/questions/22252956/android-studio-gradle-issue-upgrading-to-version-0-5-0-gradle-migrating-from-0/22256954#22256954

Pode ser o seu script gradle pode ter outros problemas após essas mudanças.