Eclipse não pode encontrar android.support.v4.widget.SwipeRefreshLayout

? Katedral Pillon @ | Original: StackOverFlow
---

Mesmo depois de clicar em Adicionar Biblioteca de suporte e escolher a versão 19, eclipse ainda não conseguiu encontrar android.support.v4.widget.SwipeRefreshLayout . Alguém sabe como chegar a este trabalho? Eu estou usando

<uses-sdk
android:minSdkVersion="11"
android:targetSdkVersion="19" />

Eu estou trabalhando em um computador Mac com mavericks Juno .

update: seção de importação

import java.util.Observer;

import android.content.Intent;
import android.os.Bundle;
import android.support.v4.app.DialogFragment;
import android.util.Log;
import android.view.View;
import android.widget.AdapterView;
import android.widget.AdapterView.OnItemClickListener;
import android.widget.ListView;
import android.widget.TextView;
import android.support.v4.widget.SwipeRefreshLayout;//red underline

Update

By the way, eu não sei se isso importa: este é um Appengine Conectado Projeto Android, que eu construir usando Google - Eclipse -Plugin

Update 3:

Está parecendo o Android Suporte Biblioteca 19.1.0 não está disponível através do Gerenciador de SDK. De que outra forma eu poderia obtê-lo ?

---

Top 5 Responder

1tehnolog @

Eu tive o mesmo problema com o projeto antigo . Mas quando eu criar novo projeto, Eclipse pode encontrar essa importação.

2user936580 @

Parece que você não tem o android -support- v4.jar em Java Build Path . Adicioná-lo a partir do android -support- v7- AppCompat .

3Katedral Pillon @

Então não é que a biblioteca é no seguinte local

/android-sdk-macosx/extras/android/m2repository/com/android/support/support-v4/19.1.0

Em oposição à habitual

/android-sdk-macosx/extras/android/support

Também eu tive que reiniciar eclipse e vá para Android SDK Manager mais e mais e mais, até que a versão 19.1.0 aparece.

Espero que esta salva alguém algum problema.

4Lee HyunSoo @

A atualização SDK Android Gerente de Suporte Biblioteca para 19.1.0 . Mas quando você usa Android Tools > Adicionar Biblioteca de suporte, atualização eclipse Android Biblioteca de suporte para 19,0 . Acho que este é um bug. Copiar Android Suporte Biblioteca 19.1.0 para libs pasta manualmente .

5birdy @

É um problema com a atualização da biblioteca apoio do eclipse : https://code.google.com/p/android/issues/detail?id=67991

Apenas atualizá-lo, iniciando gerente SDK Android manualmente e adicionar nova lib v4 ao seu projeto.