Não encontrou classe no caminho: dexpathlist

? Rodolfo Perottoni @ | Original: StackOverFlow
---

Sério, eu não sei o que fazer para resolver este problema. Meu projeto android estava trabalhando muito bem, até que eu precisava para importar uma biblioteca com Maven. Desde que, tudo começou a desmoronar.

O que está acontecendo : Quando eu começar a minha aplicação, aparece o seguinte erro em LogCat e android diz que meu aplicativo parou de funcionar. Eu procurei por esse erro semelhante aqui e no resto da internet, mas tudo que as pessoas não têm trabalhado para mim .

Error: java.lang.RuntimeException: Unable to instantiate activity ComponentInfo{com.example.buscaserra/com.buscaserra.main.ActivitySplash}: java.lang.ClassNotFoundException: Didn't find class "com.buscaserra.main.ActivitySplash" on path: DexPathList[[zip file "/system/framework/com.google.android.maps.jar", zip file "/data/app/com.example.buscaserra-2.apk"],nativeLibraryDirectories=[/data/app-lib/com.example.buscaserra-2, /vendor/lib, /system/lib]]

Manifestos e pacotes:  Não encontrou classe no caminho: dexpathlist  Não encontrou classe no caminho: dexpathlist

Caminho de Construção :  Não encontrou classe no caminho: dexpathlist

Por favor, eu não sei mais o que fazer . Meu prazo final do projeto está próximo e im desesperada . Desde já, obrigado.

---

Top 5 Responder

1code4cause @

Você tem projetos necessários no caminho de construção ? Não é possível dizer a partir de sua captura de tela, mas verifique o seu guia "Projetos" . Você pode inadvertidamente ter adicionado um Projeto Biblioteca como um projeto obrigatório vez . Remover o projeto a partir da guia e, em seguida, projeto Projetos -> propriedades . Clique Android, adicione o projeto como uma biblioteca, em vez aqui ...

2Federico @

Mesmo problema aqui. O que funcionou para mim foi a adição de android -support- v4.jar como um lib e certificando-se de que foi verificado nas propriedades do projeto -> Caminho de Construção -> Order & amp; exportação. Foi mencionado https://code.google.com/p/android/issues/detail?id=61710

3Rodolfo Perottoni @

Na época, eu estava desenvolvendo esse app, eu não podia perder mais tempo procurando por uma maneira de corrigir esse problema. Como solução, eu copiei o conteúdo deste projeto para um novo. Problema resolvido .

4JDJ @

Certifique-se de que quaisquer frascos lib de compatibilidade que você está usando em seu projeto principal (como android -support- v4.jar ) são as mesmas versões como aqueles usados ​​em qualquer um dos projetos que os seus principais referências do projeto.

Eu tive esse mesmo problema e que resolveu que era para copiar e colar o android -support- v4.jar de outro projeto de biblioteca ( que o meu principal projeto foi referenciar ) e colá-lo na pasta / libs meu principal do projeto.