Eclipse (Android Bundle ) Crashing

? curious_coder @ | Original: StackOverFlow
---

Eu recentemente atualizado para o Ubuntu 14.04 . Desde então Eclipse foi bater. A mensagem é

# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x734be86d, pid=7930, tid=3076015872
#
# JRE version: Java(TM) SE Runtime Environment (8.0_05-b13) (build 1.8.0_05-b13)
# Java VM: Java HotSpot(TM) Client VM (25.5-b02 mixed mode linux-x86 )
# Problematic frame:
# C  [libsoup-2.4.so.1+0x5486d]  soup_session_feature_detach+0x1d
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /home/funcoding/Android Development/adt-bundle-linux-x86-20131030/eclipse/hs_err_pid7930.log
#
# If you would like to submit a bug report, please visit:
#   http://bugreport.sun.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
Aborted (core dumped)

Eu também tentei adicionar -Dorg.eclipse.swt.browser.DefaultType=mozilla" para eclipse.ini

UPDATE: Eu tentei muitas coisas, mas continua a cair de forma inesperada. Finalmente eu decidi ficar com Android Studio ( Correndo sem problemas a partir de agora ) .

---

Top 5 Responder

1yqlong @

Você pode reinstalar o eclipse.

Eu tinha começado esse problema após a atualização para 14,04 . Eu baixei a última JRE, não funcionou . Então eu tenho o mais recente eclipse e agora ele funciona.

2Ian @

Esta é apenas uma correção temporária, e tenho certeza que ele não vai ser selecionado como uma resposta, mas eu estou colocando isso aqui para que qualquer pessoa com esse problema pode, pelo menos, continuar a usar o eclipse até que seja encontrada uma solução melhor.

Dicas de ferramentas parecem estar causando o problema para que eu desativado -los. Eu sou capaz de continuar com a programação e eu não tive que bater em mim de novo (ainda).

Para desativar as dicas de ferramentas ir para Windows> Preferências> Java > Editor> Paira e desmarque todo o texto pairar preferências chave modificadoras.

Espero que isso ajude .

edit:

Ele também falha quando eclipse tenta conteúdo auxiliar os usuários . Para desativar este vá para o Windows > Preferences > Java> Editor> Content Assist . Desça até Ativação Auto e desativar a ativação automática

3vitriolix @

Estou executando o Ubuntu 14.04 e estava ficando este com o pacote ADT Android do eclipse. Instalando eclipse via o Ubuntu Software Center e, em seguida, instalar o ADT via as instruções abaixo relacionados funcionou para mim.

http://developer.android.com/sdk/installing/installing-adt.html

4Logko @

Este erro foi relatado aqui: https://bugs.eclipse.org/bugs/show_bug.cgi?id=404776

Correção descrita nos comentários que funciona para mim também é adicionar essa linha no final do seu arquivo eclipse.ini

-Dorg.eclipse.swt.browser.DefaultType = Mozilla

5xcottos @

isso provavelmente não é a solução mais inteligente, mas ele definitivamente resolvido meus problemas :

depois de brincar com parâmetros eclipse.ini eu perguntei a um amigo meu que me dar seu eclipse.ini baseada em Kepler e descobri que alguns pacotes invocados no arranque foram mais recente do que os que vêm com o pacote ADT.

So I:

1) instalou uma nova cópia do Kepler 2) usou o site de atualização do Android para adicionar o quadro android 3) após reiniciar ele me pediu para atualizar o SDK Android

Até agora eu não tive qualquer acidente ( autocompletar etc.) de modo que parece que resolveu o problema ...

hope that helps

Luca