Google -play - services_lib Impossível resolver target ' android -9

? Randolphg @ | Original: StackOverFlow
---

Quando eu começo o meu ADT Android maioria, se não todos os meus projetos têm uma exclamação vermelho ao lado deles. E quando eu tento criar e executar a eles que eu recebo um erro:

"google -play - services_lib ] Não é possível resolver target ' android -9' "

Eu não sei o que isso significa que eu estou em dia com minhas atualizações com meu gerente SDK Android .

Eu tentei reiniciar eclipse. Eu tentei baixar outro SDK Android e correndo de lá, mas continua o mesmo erro .

Por favor ajude- me guiar na direção certa .

---

Top 5 Responder

1Rod_Algonquin @

sua versão do SDK mnimum em ur manifesta a sua deve ser mais do que a versão 9

2user3640330 @

Na verdade o download do último pacote ADT para Eclipse dá o mesmo erro ao tentar importar o google_play_services_lib (17). http://developer.android.com/sdk/index.html#download

Abra o Gerenciador de SDK, clique obsoleto (assim API 9 mostra -se ), e agarrar API 9. Isso realmente é algo que parece ser um simples descuido e deve ser corrigido. Espero que isso ajude os outros.

3Andrew @

Eu tive esse problema aparecer depois de instalar as atualizações mais recentes usando o ADT.

No eclipse eu tenho o meu projeto e um projeto para o google- play- services_lib .

Descobri que se você alterar a versão mínima do SDK (como dito anteriormente ) até mais de 9 não é o suficiente . Eu também tive que mudar o " destino de compilação Project" ( Propriedades / Android /) para coincidir com a versão que eu tinha definido no manifesto.

4jsanmarb @

Fixei as propriedades do projeto de definição da meta de construção do projeto :

Google -play - services_lib Impossível resolver target ' android -9

Isso funciona para mim.

5Shashidhar @

Mudança android: minSdkVersion = "9" a mais de 9 em arquivo AndroidManifest.xml isto é, android: minSdkVersion = "10" Ao fazer isso, eu resolvi o meu problema Espero que isso ajude !!