Studio Android - Construir erro de script, o método de DSL não suportado Gradle encontrado: ' android ()' !

? helloworld @ | Original: StackOverFlow
---

Estou recebendo o seguinte erro no Android 0.4.2 estúdio quando eu estou tentando sincronizar projeto com gradle .

Gradle 'GooglePlayServicesTest' project refresh failed:
       Build script error, unsupported Gradle DSL method found: 'android()'!

Meu projetos arquivo gradle é a seguinte: -

buildscript {
repositories {
    mavenCentral()
}
dependencies {
    classpath 'com.android.tools.build:gradle:0.7.+'
}
}

allprojects {
repositories {
    mavenCentral()
}
}


android{

compileSdkVersion 19
buildToolsVersion "19.0.1"

defaultConfig {
    minSdkVersion 10
    targetSdkVersion 19
    versionCode 1
    versionName "1.0"
}

sourceSets{
    main{
        manifest.srcFile 'GooglePlayServicesTest/src/main/AndroidManifest.xml'
    }
}
}

gradle arquivo de módulo: -

apply plugin: 'android'

android {
compileSdkVersion 19
buildToolsVersion "19.0.1"

defaultConfig {
    minSdkVersion 10
    targetSdkVersion 19
    versionCode 1
    versionName "1.0"
}
buildTypes {
    release {
        runProguard false
        proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt'
    }
  }
}
dependencies {
compile 'com.android.support:appcompat-v7:+'
}

também eu ter removido o miniSDKVersion e targetSDKVersion de AndroidManifest.xml

alguém pode me ajudar a resolver este erro.

---

Top 5 Responder

1fookwood @

android Método no arquivo gradle projeto não é needed.Try para removê-lo .

2hamid @

Adicionar topo do seu projeto build.gradle file:

apply plugin: 'com.android.application'