Este aplicativo não funcionará se você não atualizar Google erro serviços desempenham

? Florent Gz @ | Original: StackOverFlow
---

Estou meio perdido agora. Estou implementando um aplicativo Android usando o Google Maps .

A fim de fazê-lo funcionar eu segui alguns tutoriais que eram bastante eficiente. No entanto, eu estou preso com esta " :

Este aplicativo não funcionará se você não atualizar Google erro serviços desempenham

Para corrigir, este problema que eu encontrei alguns truques ou http://tangmmeng.wordpress.com/2013/07/10/google-play-service-on-emulator/ http://nemanjakovacevic.net/blog/english/2012/12/06/how-to-make-android-google-maps-v2-work-in-android-emulator/ que dizer que para resolver este problema que você tem que tomar uma configuração especial para o emulador, aqui é minha:

Este aplicativo não funcionará se você não atualizar Google erro serviços desempenham

e instalar algum .apk no emulador .

Este aplicativo não funcionará se você não atualizar Google erro serviços desempenham

E a magia é suposto ser feito e que o mapa deve aparecer o que não é o meu caso.

Eu verifiquei que os meus extras foram bem instalado:

Este aplicativo não funcionará se você não atualizar Google erro serviços desempenham

Aqui está o meu AndroidManifest :

<?xml version="1.0" encoding="utf-8"?>
<manifest xmlns:android="http://schemas.android.com/apk/res/android"
          package="mypack"
          android:versionCode="1"
          android:versionName="1.0">

    <uses-sdk android:minSdkVersion="16"/>

    <permission android:name="mypack.permission.MAPS_RECEIVE"
                android:protectionLevel="signature"/>
    <uses-permission android:name="mypack.permission.MAPS_receive"/>

    <!-- Permission pour utiliser la connexion internet -->
    <uses-permission android:name="android.permission.INTERNET" />
    <!-- Permission permettant de vérifier l'état de la connexion -->
    <uses-permission android:name="android.permission.ACCESS_NETWORK_STATE" />
    <!-- Permission pour stocker des données en cache de la map -->
    <uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE" />
    <uses-permission android:name="com.google.android.providers.gsf.permission.READ_GSERVICES" />
    <uses-permission android:name="android.permission.ACCESS_COARSE_LOCATION" />
    <uses-permission android:name="android.permission.ACCESS_FINE_LOCATION" />

    <uses-feature
            android:glEsVersion="0x00020000"
            android:required="true" />

    <application android:label="@string/app_name" android:icon="@drawable/ic_launcher">
        <meta-data
                android:name="com.google.android.maps.v2.API_KEY"
                android:value="MYKEY" />

        <meta-data android:name="com.google.android.gms.version"
                   android:value="@integer/google_play_services_version" />

        <activity android:name="Home"
                  android:label="@string/app_name">
            <intent-filter>
                <action android:name="android.intent.action.MAIN"/>
                <category android:name="android.intent.category.LAUNCHER"/>
            </intent-filter>
        </activity>
    </application>

</manifest>

Aqui está o meu MainActivity

import android.app.Activity;
import android.os.Bundle;
import com.google.android.gms.maps.GoogleMap;
import com.google.android.gms.maps.MapFragment;

public class Home extends Activity {
    /**
     * Called when the activity is first created.
     */
    private GoogleMap map;
    @Override
    public void onCreate(Bundle savedInstanceState) {
        super.onCreate(savedInstanceState);
        setContentView(R.layout.main);
        map = ((MapFragment) getFragmentManager().findFragmentById(R.id.map)).getMap();
    }
}

eo layout correspondente:

<?xml version="1.0" encoding="utf-8"?>
<LinearLayout xmlns:android="http://schemas.android.com/apk/res/android"
              android:orientation="vertical"
              android:layout_width="fill_parent"
              android:layout_height="fill_parent"
        >
    <fragment xmlns:android="http://schemas.android.com/apk/res/android"
              android:id="@+id/map"
              android:name="com.google.android.gms.maps.MapFragment"
              android:layout_width="match_parent"
              android:layout_height="match_parent" />
</LinearLayout>

Esperança de encontrar alguma correção ou o que eu perdi aqui, agradeço antecipadamente .

---

Top 5 Responder

1BladeCoder @

No Gerenciador de SDK Android, você deve instalar o " APIs do Google ( x86 Sistema de Imagem) " em " Android 4.4.2 (API 19) " . Saia do Eclipse e reiniciá-lo .

Em seguida, crie um novo dispositivo virtual android no gerenciador de AVD e escolha " x86 Google APIs (Google Inc.) - API Nível 19 ", como alvo. Marque a opção " Use GPU host" para assegurar a elaboração de um mapa será acelerado .

É isso aí, este novo emulador terá Tocar Serviços pré-instalado e ele vai correr mais rápido porque é uma imagem de x86.

2dvrm @

usando estúdio android, a única coisa que me ajudou foi a redução da versão serviços Google Play no arquivo gradle da última versão a esta :

compile 'com.google.android.gms:play-services:4.2.+'