Genymotion no Windows 7 não é capaz de se conectar ao meu dispositivo virtual

? more whirlpools @ | Original: StackOverFlow
---

Tenho vindo a utilizar Genymotion por cerca de um mês, e funcionou bem . No entanto, durante a semana passada eu tenho recebido esse erro, independentemente das minhas configurações:

Genymotion no Windows 7 não é capaz de se conectar ao meu dispositivo virtual

"Não é possível se conectar ao seu dispositivo virtual! Genymotion pára. Verifique a sua configuração de rede VirtualBox. "

e um link para mais informações :  https://cloud.genymotion.com/page/faq/#collapse-nostart

Tenho seguido os passos lá, eo emulador ainda não funciona .

Estou executando o Google Nexus 4 - 4.4.2 - API 19 - 768x1280 e tentei com vários emuladores de diferentes APIs e tipos. Eu também estou correndo um 64-bit sistema operacional Windows 7 .

Eu tenho desinstalado e reinstalado tanto Genymotion e VirtualBox, e eu ainda obter o mesmo erro . A partir da visualização emulador no VirtualBox, o emulador parece estar funcionando normalmente, mas Genymotion é incapaz de se conectar a esse dispositivo. Executando o emulador do VirtualBox parece funcionar bem ; infelizmente não posso ligar para o Eclipse de lá.

Como faço para corrigir isso? A única coisa é que o emulador funcionou antes, e ele não funciona agora.

---

Top 5 Responder

1more whirlpools @

EDIT: Acontece que Genymotion tem problemas enquanto seu usuário está executando uma VPN, explicando os problemas de conexão .

Fixei -me.

O problema maior parte envolvida minha ligação à Internet .

O servidor DHCP que Genymotion estava usando estava tentando entrar em contato com o endereço IP não utilizado 0.0.0.100, o que levou a lugar nenhum.

Portanto, ele levou o VirtualBox e Genymotion para escolher as configurações erradas para o servidor DHCP e do endereço IPv4. Assim, a minha solução foi para desativar todas as conexões com a Internet antes de eu começar Genymotion, e conseguiu correr sem problemas .

2msoliman @

Uma boa resposta descritiva para resolver esse problema é http://stackoverflow.com/a/20018833/1334561 em outro post. Além disso, poderia ser encontrada a solução em https://www.genymotion.com/#!/support?chapter=collapse-nostart#faq sob a seção denominada " Quando eu começo um dispositivo virtual, por que é que a janela permanecer em preto ? "

3user1679544 @

Eu enfrentei esse problema e eu soloved como este:

1) Vá para VirtualBox > Arquivo> Preferências > guia Nework

2) Selecione VirtualBox - Anfitrião Only- Ethernet Adapter em Redes host-only ; e, em seguida, excluí-lo.

3) Reinicie o dispositivo virtual