Android Estúdio Gradle buildtools Revisão

? Gabriel Matusevich @ | Original: StackOverFlow
---

Eu tenho um projeto Android no Android 0.5.9 Estúdio e Gradle está jogando esse erro:

Error:The SDK Build Tools revision (17.0.0) is too low. Minimum required is 19.0.0

Eu já instalei o SDK Ferramentas de construção Revisão 19 a partir do Gerenciador SDK e aqui é a minha build.gradle

buildscript {
    repositories {
        mavenCentral()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:0.10.+'
    }
}
apply plugin: 'android'

repositories {
    mavenCentral()
}

android {
    compileSdkVersion 17
    buildToolsVersion "19.0.0"

    defaultConfig {
        minSdkVersion 9
        targetSdkVersion 17
    }

    sourceSets {
        main {
            manifest.srcFile 'Manantiales/src/main/AndroidManifest.xml'
        }
    }
}

Como eu digo gradle para usar as ferramentas de compilação 19 se ele já está instalado?

EDIT: Eu marquei uma resposta diferente como a melhor resposta, pois foi o que funcionou para a maioria das pessoas

---

Top 5 Responder

1Gabriel Matusevich @

Eu encontrei o problema, build.gradle estava na pasta errada

2Azurai @

Eu atualizei recentemente meu estúdio para android 0.6.0, e isso estava me dando o mesmo problema. Mas o meu corpo era 19.0.3, em vez de 19.1.0 . Mudei o buildToolsVersion " 19.0.3 " para -> " 19.1.0 ", que forçou o Gradle para baixar as atualizações . Eu reiniciei meu estúdio Android, e que o erro foi embora. Não tenho certeza exatamente como explicar, mas eu acho que o obriga a baixar o patch fora do local do Maven, e faz a sua justiça atrás de cenas. E tal como disse Gabriel Matusevich, o build.gradle está localizado ProjectFolder -> AppFolder -> build.gradle

Exceção: I hav não completou testei isso, mas eu notei o Gradle foi baixado a partir do site, eu hav não adicionados ou código excluído, ou executou o aplicativo ainda. Então, com certeza, lembre-se o número buildToolsVersion você tinha antes !

3Jorge Vieira @

Abra o Gerenciador Android SDK e certifique-se que você tem Ferramentas de construção 19,1 baixados. Verifique duas vezes .

Em seguida, encontrar construir / app.gradle e alterar o número buildToolsVersion para '19 .1 ':

apply plugin: 'android'

android {
    compileSdkVersion 19
    buildToolsVersion '19.1'
    defaultConfig {
        minSdkVersion 10
        targetSdkVersion 19

    }
4Xexiz @

Eu tive o mesmo problema esta manhã após a atualização para .6.0 . Você precisa mudar você versão gradle em /projectName/build.gradle

classpath 'com.android.tools.build:gradle:0.11.+'

Abra o seu gerente SDK e baixar a nova versão das ferramentas de compilação de 19,1, em seguida, altere a seguinte linha em /projectName/moduleName/build.gradle

android {
  compileSdkVersion 19
  buildToolsVersion "19.1" //This version needs to be updated to 19.1 after SDK update

  ...

}

Em seguida, sincronize seus arquivos gradle e você deve ser bom para ir !

5RoQ @

Oi para mim depois de fazer o download da última versão das ferramentas do Android SDK, eu mudo a versão android F4 ( Module Settings )

https://www.dropbox.com/s/9ypuepxfwlcp4e5/Captura%20de%20pantalla%202014-06-10%2000.45.38.png