Erro no Eclipse com appcompat_v7

? jkally @ | Original: StackOverFlow
---

Ser novo developent Android Segui o mais simples dos tutoriais, construiu um novo projeto Android, aceitando tudo default ( construiu para KitKat ) . Para meu espanto Eu tenho um projeto planejado un - appcompat_v7, juntamente com os erros :

O recipiente referências ' Dependências Android "não biblioteca existente ' C: ? Usuários ... workspaceappcompat_v7 inappcompat_v7.jar '

e duas vezes a seguinte

O projeto não pode ser construído até erros de caminho de construção são resolvidos

Existe uma maneira rápida para corrigir isso? É este um sinal de quão difícil e grampeado com surpresas desagradáveis ​​aprendizagem Android vai ser ?

( Espero que não será semelhante ao aprendizado IOS 6 anos atrás ... )

---

Top 5 Responder

1ZygoteInit @

O truque é, você precisa limpar & amp; construir o projeto appcompat_v7 . Vá em Project -> selecione Clean -> selecione o projeto . Se o projeto não é construído automaticamente, clique direito sobre o projeto no pacote de explorar e selecione Build Project . Agora, o .jar arquivo será gerado na pasta bin do projeto. Depois disso, clean & amp; construir todos os projetos que fazem referência a appcompat_v7 .

Note also that:

1. Você deve ter as últimas versões do SDK Tools / Ferramentas de Construção / Ferramentas plataforma. Se você tentar isso e ele não funcionar, então vá para o Gerenciador SDK Android e ter certeza de que as últimas versões das ferramentas necessárias.

2. No caso do seu projeto requer apenas nível API 14 ( Ice Cream Sandwich ) & amp; acima, selecione o nível API 14 para " mínimo exigido SDK" no assistente de projeto quando você cria um novo projeto. Agora, a biblioteca appcompat_v7 não será exigido para este projeto, e o aplicativo usará a classe ActionBar nativa que está presente em AOSP constrói a partir ICS em diante.

2prabhakaran @

Precisa atualizar seu gerente SDK

clique ur ícone gerente SDK no ecilipse então atualizar Repository apoio android nos extras

then

vá em File- > de importações > projeto existente

Abt bundle- > sdk- > extra- > android- > Support- > v7 para espaço de trabalho

após v7 importação para espaço de trabalho vá para a pasta lib escolher tanto jar e clique direito e escolha a construir espaço de trabalho, em seguida, novamente projecto v7 clique direito ir a caminho de construção java escolher a caixa de seleção e clique em Aplicar e em OK ..

se vc tiver atualizado sdk siga esses passos

step 1:

Clique com o botão direito ur projeto depois ir para

propriedade- > escolha do caminho de construção java

step 2:

clique em Adicionar JAR externo

Step 3:

Navegue até ur pacote ADT ir para ur espaço de trabalho escolha a pasta

- android -support v7- AppCompat -> lib -> appcompat_v7.jar

3CyberSpy_zero @

Eu tive o mesmo problema e eu tentei todos mentionded acima conselhos e muito mais a partir, mas ninguém me ajudou a resolver o meu problema. Minha solução foi criar um progect com mínima exigida SDK API 14: Android 4.0 ( IceCreamSandwich ) . Fazendo dessa forma Eclipse não criará appcompat_v7 projeto.

Também achei outra, melhor, solução :

Go to Android SDK Manager and install Android 5.0.1 (API 21) or newer. If you don't use the emulator you can install only SDK Platform and Google APIs; Go to appcompat_v7 -> Properties -> Android and check Android 5.0.1 in the Project Build Target; Then go to Java Build Path -> Order and Export and check Android 5.0.1; Do the same procedure for your project. 4BK Manly @

Appcompat_7 erro resolvido!

Oi, sou um novato completo, i resolveu o meu problema por ir para a atualização gerente SDK / instalar todo o novo Android SDK construir ferramentas (como eu não tenho certeza que é o que eu deveria atualizar / instalar assim que eu atualizar / instalar todas as ferramentas de compilação . Depois atualizado / instalado todas as ferramentas de compilação Fechei eclipse e relançar o eclipse novamente. Se você ver qualquer erro de novo? ir para o topo, clique em Project bar e escolha Limpar . e executar o aplicativo novamente, e eu acho que vai funcionar bem ..

5Don 3000 @

A resposta aceita trabalhou para mim, mas só depois de eu ter instalado a última Java JDK (que foi uma solução para o problema detalhado aqui http://stackoverflow.com/questions/26474298/android-parsing-data-for-android-21 -failed )