Tenho um erro ao construir um projeto no novo espaço de trabalho

? Harikrishnan @ | Original: StackOverFlow
---

Sou novo para o desenvolvimento android . Eu tentei criar um novo espaço de trabalho com a Target SDK como API 21 e Compilado com API 19. Eu instalei o SDK de API19 e 20 e não o Android5 . Eu criei um novo espaço de trabalho e criou um novo projeto em que eu acabei com o erro abaixo ao compilar o projeto depois de criá-la. Alguém pode me ajudar como se livrar disso?

Error details:

---

Top 5 Responder

1QArea @

Queria mudar destino de compilação do projeto para Android 4.4.2 também?

Aqui caras tinham o mesmo problema: http://stackoverflow.com/a/14843198/3864698

2Muhammad Ebad @

Uma das anteras coisa que você pode tentar é para abrir o arquivo project.properties do android -support- v7- AppCompat e mudar o alvo alvo. E depois é só fazer um projeto - > Clean para que as alterações tenham efeito .

3Andy Dent @

Eu tenho um erro semelhante como alguém novo para a instalação de ferramentas do Android e ter equivocadamente selecionou a 4.4W, bem como 4.4.2 no Gerenciador SDK Android .

Isso resulta em ter tanto API 20 e API 19 instalado, o que significa 20 API parece ser mais novo e vai ser pego por padrão para novos projetos.

No entanto, API 20 é apenas Wearables .

Você pode ver aqui em Tenho um erro ao construir um projeto no novo espaço de trabalho que 4.4W acabou no caminho.

Tanto o appcompat_v7 e metas do projeto HelloAndy tive esse problema caminho .

Eu editei project.properties para tanto e mudou target = android- 20 a target = android -19, em seguida, fez uma atualização em ambos os projetos ( clique com o botão direito do mouse no appcompat_v7 e outro projeto ) . Que atualizou os caminhos de construção para apontar para o Android SDK correto.

4pokerface @

Atualize o arquivo de project.properties AppCompat v7, que tem : target=android-19 para target=android-21

Também atualização google play services biblioteca (por update Quero dizer atualizá-lo em SDK Manager e re- importação etc )

5Adgaonker Shashank @

Basta remover essa linha estilo whereever erro for encontrado, em seguida, limpar o seu projeto

e fazer o seu projeto 5.0 setado