Google ADT / apoio GWT para Eclipse 4.4 ( Luna )

? MTilsted @ | Original: StackOverFlow
---

Já alguém recebeu a versão do eclipse 4.4 para trabalhar com o ADT ( Android desenvolvimento ) e / ou google Web Toolkit (GWT) .

Parece que os GWT / plugins ADT não trabalha com eclipse 4.4, assim há um lugar secreto para download de novas versões ou devo continuar usando 4.3 - (

Edit: A razão pela qual eu pensei ADT não estava funcionando era de que a documentação ( http://developer.android.com/sdk/installing/installing-adt.html ) diz que o plugin é chamado de " ADT Plugin ", o que não é.

---

Top 5 Responder

1user3396807 @

For adt,

Ajuda -> instalar um novo software ->    https://dl-ssl.google.com/android/eclipse/ -> não selecionar tudo

( funcionou dessa maneira para mim) eu selecionei tudo, exceto as ferramentas de desenvolvimento nativo ( eu acho que você não precisa deles, se você debelop em java) e ele está funcionando bem para mim.

2raywang @

bem ... o plugin gwt realmente não pode trabalhar com liberação de luna, uma vez que tem uma dependência pacote para eclipse core.runtime [ 3.8.0,3.10.0 ), aqui, ")" significa que não inclui 3.10.0 wihich é usado em luna no entanto, ele pode se livrar de, modificando o arquivo OSGi e, em seguida, ele vai funciona bem com luna, pelo menos para mim por enquanto.

1 baixar o último arquivo zip site de atualização do Google Site plugin do Eclipse 2 descompactá-lo 3, então você vai precisar modificar 2 arquivos em primeiro lugar

um arquivo META INF / manifest OSGi incluído em um frasco chamado * gdt * E42 (desculpe, esqueci o nome completo, você pode encontrá-lo quando você está tentando instalar o plugin, luna se queixam de que algum pacote dep é perdida ), que está localizado em plugins dir, basta alterar core.runtime versão de 3.10.0 ) para 3.10.0 ]

outra deve ser contents.jar (talvez artefatos. jar ), mesmo acima

agora você pode instalar o plugin se você já o RCP eclipse instalado

no entanto, vai instalar falhou porque o hash MD5 é alterado,

finalmente, copie o md5 esperado de diálogo mensagem de erro para substituir o valor md5 velho em artifacts.jar (talvez contents.jar )

agora reinstalar o plugin, ele deve trabalhar para agora

UPDATED:

talvez você deve remover o pacote da versão de MANIFEST.MF em jar com.google.gdt.eclipse.platform.e42 e alterar a versão de " 0.0.0 " do content.xml em content.jar

3MrTux @

Google acaba de lançar seu SDK oficial do Eclipse Luna: https://developers.google.com/eclipse/docs/getting_started

4ojonugwa ochalifu @

Se você estiver usando a opção Help----->Install New Software, você pode encontrar essa mensagem de erro assim como eu fiz tentando instalar o plugin Android .

An error occurred during the org.eclipse.equinox.internal.p2.engine.phases.CheckTrust phase. session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.CheckTrust, operand=, action=). Error reading signed content. error in opening zip file

Minha solução foi passar por Help-->Eclipse Marketplace e, em seguida, procure por "Android" Selecione o plug-in a partir do resultado da pesquisa e instalá-lo de lá.