Atualização Eclipse com ferramentas de desenvolvimento Android v . 23

? greywolf82 @ | Original: StackOverFlow
---

Eu atualizei Eclipse com as novas ferramentas do SDK (Ap 23), mas agora, quando Eclipse começa recebo o erro:

Este SDK Android requer Android Developer Toolkit versão 23.0.0 ou superior. A versão atual é 22.6.3.v201404151837-1123206 . Por favor, atualize ADT para a versão mais recente .

Não há atualizações foram encontrados em "Verificar atualizações" . Se eu tentar " Instalar um novo software ", eu posso ver a versão 23, mas eu não posso atualizar devido ao seguinte erro:

Cannot complete the install because of a conflicting dependency.
Software being installed: Android Development Tools 23.0.0.1245622 (com.android.ide.eclipse.adt.feature.feature.group 23.0.0.1245622)
Software currently installed: Android Developer Tools 22.2.1.v201309180102-833290 (com.android.ide.eclipse.adt.package.product 22.2.1.v201309180102-833290)
Only one of the following can be installed at once: 
    ADT Package 22.6.3.v201404151837-1123206 (com.android.ide.eclipse.adt.package 22.6.3.v201404151837-1123206)
    ADT Package 23.0.0.1245622 (com.android.ide.eclipse.adt.package 23.0.0.1245622)
Cannot satisfy dependency:
    From: Android Development Tools 23.0.0.1245622 (com.android.ide.eclipse.adt.feature.feature.group 23.0.0.1245622)
    To: com.android.ide.eclipse.adt.package [23.0.0.1245622]
Cannot satisfy dependency:
    From: Android Development Tools 22.6.3.v201404151837-1123206 (com.android.ide.eclipse.adt.feature.group 22.6.3.v201404151837-1123206)
    To: com.android.ide.eclipse.adt.package [22.6.3.v201404151837-1123206]
Cannot satisfy dependency:
    From: ADT Package 22.2.1.v201309180102-833290 (com.android.ide.eclipse.adt.package.feature.group 22.2.1.v201309180102-833290)
    To: com.android.ide.eclipse.adt.feature.group 22.2.0
Cannot satisfy dependency:
    From: Android Developer Tools 22.2.1.v201309180102-833290 (com.android.ide.eclipse.adt.package.product 22.2.1.v201309180102-833290)
    To: com.android.ide.eclipse.adt.package.feature.group [22.2.1.v201309180102-833290]

Após o download da última ADT partir do web site, parece que há um outro problema. Com SDK Tools rev. 23 proguard não estiver instalado, a pasta SDK dir/tools/proguard está faltando e outras ferramentas estão em falta. Esta versão contém vários bugs.

---

Top 5 Responder

1Daniel Díaz @

UPDATE: O Google lançou ADT v23.0.2 . Isso resolveu muitos problemas da versão anterior ADT 23 .

Step-by-step:

Help -> Install New Software... For "Work with", select the Android source https://dl-ssl.google.com/android/eclipse Atualização Eclipse com ferramentas de desenvolvimento Android v . 23 Tick ADT v23.0 for installation, then click "Next" Eclipse will show "Install Remediation Page" since there is conflict with previous version. (If it does not, see below.) Select "Update my installation to be compatible with items being installed" to uninstall the old version and install the new one. After that, proceed with the usual steps Atualização Eclipse com ferramentas de desenvolvimento Android v . 23

Nota: Quando eu instalei a nova versão do ADT, eu não inclui a nova versão do pacote " Android Development Tools nativos " . Em vez disso, eu instalei o resto de pacotes antes, e depois instalado " Android Development Tools nativo" . Por uma razão, se eu tentar instalar todos os novos pacotes, incluindo " Android Development Tools Native ", a instalação falhará.

UPDATE: Se não há " página Remediação ", http://stackoverflow.com/a/9097282/755804 Mas há um risco de desinstalação eclipsar -se .

2bluewhile @

Para mim, isso ajudou a apagar 4.4W Android que também é API 20 e pode ser uma causa para o conflito. Assim, apenas instalar o Android 4.4W ou Android L até que corrigi-lo.

E (mais uma vez isso pode ser só para mim ) que só funciona em Android Studio não em Eclipse ...

3Rajat Sharma @

Eu tenho feito a seguir para resolver um problema .

Ir para http://developer.android.com/sdk/installing/installing-adt.html e fazer o download do arquivo mais recente ZIP ADT ( na parte inferior da página ) .

Ir para o Eclipse - > Ajuda - > Sobre o Eclipse -> Detalhes da instalação

Excluir Android DDM, Android Development Tools, Hierarchy Viewer, Ferramentas de Desenvolvimento Indígena, TraceView, etc, versão 22.x .

Ajuda -> Instalar Novo Software - > Adicionar - > Arquivo - > Selecione o arquivo ZIP baixado na etapa 1.

Selecionar tudo a versão mais recente de todos os 23 que eu tenha apagado na etapa 3 e aceitar o contrato de licença.

Reinicie Eclipse, e ele corrige o meu problema .

4stevyhacker @

Na ADT empacotado Eclipse eu tive que desinstalar primeiro a ADT e depois fazer uma nova instalação . Para remover o plugin ADT de Eclipse vá para Ajuda > Sobre o Eclipse > Instalação detalhes. Selecione o plug-in ADT, em seguida, clique em Desinstalar. Após a desinstalação instalar ADT de Ajuda> Instale o novo software.

5Biljana @

DO NOT DO THIS

Aviso: Por favor, veja os comentários abaixo esta resposta . Estas medidas tiveram um impacto negativo para muitas pessoas.

Click Help / Install new software... Click on What is "already installed" (as in picture below) In the new window you can uninstall the old ADT (uninstall Android Development Tools, Android DDMS, Android Hierarchy Viewer, Android TraceView, Android Native Development Tools and Tracer for OpenGL ES) Restart Eclipse Then again click on Help / Install New Software Choose ADT... Install

Espero que ajude !

Atualização Eclipse com ferramentas de desenvolvimento Android v . 23