0.8.9 UnsupportedMethodException Android Estúdio

? user3184899 @ | Original: StackOverFlow
---

Tenho Android Estúdio 0.8.9 . Até agora, conseguiu sincronizar com arquivos gradle com sucesso , Mas hoje, quando eu abri -lo, dá-me este erro:

UnsupportedMethodException
         Failed to set up Android modules in project 'Project': Unsupported method: SourceProvider.getJniDirectories().
         The version of Gradle you connect to does not support that method.
         To resolve the problem you can change/upgrade the target version of Gradle you connect to.
         Alternatively, you can ignore this exception and read other information from the model.

Pode me ajudar a resolver isso? Obrigado.

---

Top 5 Responder

1Danuofr @

Para corrigir esse problema eu down- graduada o android -plugin em seus projetos top de arquivo nível de build.gradle     classpath ' com.android.tools.build:gradle:0.14.+ ' para     classpath ' com.android.tools.build:gradle:0.13.+ '

Então, agora o método buildscript em meus projetos build.grade parece

buildscript {
  repositories {
    mavenCentral()
  }
  dependencies {
    // NOTE: Do not place your application dependencies here; they belong
    // in the individual module build.gradle files
    classpath 'com.android.tools.build:gradle:0.13.+'
  }
}

Eu acho que pode haver um bug com a versão .14, enviei o meu relatório de erro.

2Jeff Brateman @

Tal como afirmado por http://stackoverflow.com/questions/26680972/unsupportedmethodexception-android-studio-0-8-9#comment42031754_26692486, A atualização para o Android 0.9.0 Estúdio corrige esse problema .