Android Wear Projeto Gradle sincronização falha

? Eliezer @ | Original: StackOverFlow
---

Eu criei um novo projeto no Android Estúdio 0.8, a fim de começar a integrar Android Wear em um dos meus apps. Eu criar um novo projeto e incluir o fator de forma de vestir, mas quando eu tento sync eu recebo:

Erro: Não foi possível encontrar qualquer versão que corresponde com.google.android.support:wearable:+ .     Requerido por:         win_control : vestir: não especificado

EDIT: Eu brinquei com Gradle um pouco, e agora eu recebo esses erros:

Erro: Não foi possível encontrar : com.google.android.gms : -services play- wearable : +     Open in Estrutura do Projeto Arquivo dialogOpen

Erro: Não foi possível encontrar : com.google.android.support:wearable:+     Open in Estrutura do Projeto Arquivo dialogOpen

---

Top 5 Responder

1nickjm @

Tive o mesmo problema. Abra o seu gerente SDK Android, vá em Ferramentas -> gerenciar adicionar em sites, e adicione seu próprio repo :

https://dl-ssl.google.com/android/repository/addon-play-services-5.xml

Eu finalmente encontrei esses guias úteis . Há lotes de links quebrados e má informação flutuando, mas estes devem funcionar:

http://developer.android.com/preview/google-play-services-wear.html

then,

http://developer.android.com/training/wearables/apps/creating.html

Além disso, verifique novamente se o seu gerente de Android SDK para se certificar de que você tem todas as últimas atualizações, bem como os android repositório apoio / bibliotecas !

2CyberDandy @

Eu descobri que, a partir de Android Estúdio 0.8.1, a opção " Manage Add -On Sites " está ausente do menu Ferramentas. Apenas no caso de alguém não pode encontrá-lo tanto, veja aqui como chegar a ele :

1 / Vá em Ferramentas > Android > Gerenciador SDK.

2 / Em seguida, uma vez que o Gestor de SDK é aberto, no menu superior, vá em Ferramentas > Manage Add -On Sites .

Lá vai você, então você simplesmente aplicar o que disse nickjm ( obrigado pela dica btw, eu queria saber o que estava acontecendo com essa mensagem de erro !).

3user3196061 @

Adicionando o add no local não funcionou para mim. No Android SDK, eu simplesmente abriu : Ferramentas-> Opções da ...-> Ativar Ferramentas Preview ( Confira ) Em seguida, ele teve uma atualização para o material de desgaste ... o que eu, é claro, atualizado.

Isso permitiu que a biblioteca a ser referenciado pelo IDE.

4Sveinung Kval Bakken @

Se o gerente SDK não encontrar nenhuma atualização para vocês, que ajudou para que eu limpe a pasta m2repository em ~/.android/extras/google/ .

Você pode adicionar manualmente o site de atualização usando o seu editor de texto favorito em ~/.android/repositories.cfg, ele deve ser parecido com isto:

### User Sources for Android SDK Manager
#Wed Jul 02 10:15:39 EDT 2014
count=1
src00=https://dl-ssl.google.com/android/repository/addon-play-services-5.xml
5ekatz @

Se tudo isso não funcionar para você, confira as instruções em https://code.google.com/p/android/issues/detail?id=72454 Para mim, eu simplesmente estava faltando Google Repository da seção de extras no gerenciador sdk