Erro no ADT 23 Atualização

? Gödel77 @ | Original: StackOverFlow
---

em primeiro lugar, eu sei que é uma pergunta freqüente, mas de modo que eu estou aqui desde um par de semanas que eu não tenho reputação suficiente para comentar nos tópicos .

Bem, eu tentei fazer tudo o que nos -threads questão, mas sem sucesso (com https e sem, ADT23.zip baixar também :()

Isso é o que eu tenho

Cannot complete the install because of a conflicting dependency.
  Software being installed: Android DDMS 23.0.0.1245622 (com.android.ide.eclipse.ddms.feature.feature.group 23.0.0.1245622)
  Software currently installed: Android Developer Tools 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.adt.package.product 22.6.2.v201403212031-1085508)
  Only one of the following can be installed at once: 
    Dalvik Debug Monitor Service 23.0.0.1245622 (com.android.ide.eclipse.ddms 23.0.0.1245622)
    Dalvik Debug Monitor Service 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.ddms 22.6.2.v201403212031-1085508)
  Cannot satisfy dependency:
    From: ADT Package 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.adt.package.feature.group 22.6.2.v201403212031-1085508)
    To: com.android.ide.eclipse.ddms.feature.group 22.6.2
  Cannot satisfy dependency:
    From: Android Developer Tools 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.adt.package.product 22.6.2.v201403212031-1085508)
    To: com.android.ide.eclipse.adt.package.feature.group [22.6.2.v201403212031-1085508]
  Cannot satisfy dependency:
    From: Android DDMS 23.0.0.1245622 (com.android.ide.eclipse.ddms.feature.feature.group 23.0.0.1245622)
    To: com.android.ide.eclipse.ddms [23.0.0.1245622]
  Cannot satisfy dependency:
    From: Android DDMS 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.ddms.feature.group 22.6.2.v201403212031-1085508)
    To: com.android.ide.eclipse.ddms [22.6.2.v201403212031-1085508]

Como posso resolver isso?

Thanks

---

Top 5 Responder

1Jitu @

Estava enfrentando o mesmo problema, Respondida por desinstalar a versão anterior do ADT completamente e, em seguida, instalar a nova versão .

Try it out.

2user3775520 @

Ele funciona para mim :)

Se por algum motivo você instalou uma pré-visualização ADT e precisar voltar para a corrente estável, você não pode usar o diálogo para instalar o software "novo" já que o que você quer é, na verdade, um mais antigo. Em vez disso, faça o seguinte:

Open Help > About Eclipse... on Windows or Linux. On Mac, use the app's menu > About... Click the "Installation Details" button. Select the "Installation History" tab. Select one of the previous configurations. Click the "Revert" button at the bottom.

Erro no ADT 23 Atualização

3Ingo @

Você tem que atualizar o seu Google ADT para a versão mais recente !

Em Eclipse vá para Ajuda

Instalar um novo software ---> Adicionar

dentro Adicionar write Repository:

https://dl-ssl.google.com/android/eclipse/

Clique duas vezes na abertura da caixa de entrada 1 .

Siga as instruções do Eclipse.

Depois de colocar algum tempo você vai obter os mais novos Developer Tools e NDK Plugins

Repita esse procedimento para 2 vezes

Tom

4sibel_aflazi @

Eu estava usando Eclipse Luna . Eu fiz o download do SDK 23. Então, quando eu ler ADT 23 lançado eu estava animado . Eu baixei -lo também. Mas eu relised ele tem muitos erros. Eu não podia fazer nada com eclipse. Eu pensei que o outro, ADT 22 foi boa.

Então eu comecei a usar Kepler novamente. Eu instalar SDK 22.6.2 e 22.6.2 ADT também. Estou feliz agora. Eu tenho mais nenhum erro .

Se estiver em execução, não toque nele !

5SeekingAlpha @

Eu baixei Eclipse Luna sem ADT. Isto é importante .

Dependendo de onde você salvou o seu espaço de trabalho e qual versão do eclipse que você estava usando antes de um pop-up pode aparecer dizendo que vai migrar para o Eclipse Luna etc2 . Eu escolhi a migrar para Luna .

Então eu fui para ajudar -> instalar um novo software e acrescentou o plugin ADT via https://dl-ssl.google.com/android/eclipse .

Eu tenho que correr o meu app eu estava desenvolvendo em ADT 22.xx e ele funciona muito bem no emulador e minha própria nexus 5 .

Espero que isso ajude .....