Não é possível criar um emulador com Android L ( API 20)

? CHAKRAVARTHI @ | Original: StackOverFlow
---

Eu atualizei a ADT 23 e gerente SDK com Android L ( API 20 L preview), mas eu não estou recebendo o "L Android " na lista de destino .

Feito reiniciar o eclipse muitas vezes. não funciona. Alguém por favor me diga o que eu estou fazendo de errado .

---

Top 5 Responder

1My God @

Solução direto do fórum -

Houve uma muito recente mudança para Android Studio. Faz Android -L (API 20), que foi anunciado hoje, o SDK de destino padrão . Você está recebendo o erro porque ele está procurando o Android -L e não pode encontrá-lo . Nossa lição foi preparada com KitKat Android (API 19) em mente.

Try installing:

L Android (API 20, L Preview) SDK da plataforma Android L Prévia Intel Atom Sistema x86 Imagem

e ver se isso resolve o seu problema. À luz do Android L Preview, estamos trabalhando para avaliar quais as mudanças precisam ser feitas .

Aqui é a solução para http://forums.udacity.com/questions/100199230/error-failed-to-find-target-android-l .

2Priyank @

Antes de instalar as mais recentes ferramentas de gerente SDK, tente atualizar ADT Plugin de Ajuda -> Verificar atualizações.

Então, primeiro você tem que instalar mais recentes ferramentas do SDK, plataforma de ferramentas, e Build- tools.

Depois de instalar as mais recentes ferramentas, você terá seções Android L e Android 4.4W :

Siga abaixo setps para baixar o SDK

Start the Android SDK Manager. In the Tools section, select the latest Android SDK Tools, Platform-tools, and Build-tools. Select everything under the Android L Developer Preview section and click Install packages... Accept the Licensing Agreement for all of the packages and click Install.

Nota: O Eclipse ADT plug-in requer Java 7, se seu alvo é a compilação L preview para desenvolvedores .

3CHAKRAVARTHI @

Trabalhando agora, como eu matei o processo a partir do Gerenciador de tarefas e reiniciado.

Mas tinha outros problemas . Daí eu baixei a última versão do Eclipse ( Juno ) + Android SDK pacote que inclui ADT 23 plugin.

Agora tudo funciona bem.

Clique https://developer.android.com/sdk/index.html para download.

Não se esqueça de definir a configuração do seu emulador de opções Snapshots, Use GPU anfitrião desmarcada.

4Anand @

Para aqueles que estão ficando preso na tela preta :

Tente ativar " Use GPU Anfitrião ", enquanto a criação de um dispositivo.

5diptia @

As seguintes configurações me ajudou a criar um emulador Android L com sucesso :

Dispositivo : Nexus 5

Alvo: Android L visualização ( Certifique-se de API 20 pacotes são instalados conforme descrito nas respostas acima)

CPU / ABI : Intel Atom x86

Skin WQVGA400

RAM: 2048 VM Heap : 64

Opções de emulação Snapshots, Use GPU anfitrião desmarcada.

O emulador demorou um pouco para carregar, mas foi bem-sucedida, em última instância .