Android Estúdio diz para usar Gradle 1.10 - mas a nova versão é 1,12 ?

? KickingLettuce @ | Original: StackOverFlow
---

The error:

The project is using an unsupported version of Gradle.  Please use version 1.10.


My `gradle.build` file says this:

dependencies {
      classpath 'com.android.tools.build:gradle:0.12.+'
}

Até onde eu sei, a linha acima está correto. Meu arquivo gradle-wrapper, diz:

distributionUrl=http://services.gradle.org/distributions/gradle-1.12-all.zip

Isso aconteceu quando eu baixei o mais novo beta Android Studio ( v.8 ) e tentou importar um aplicativo que tinha, o que eu suponho que é uma versão antiga do Gradle .

Além disso, quando eu bati " Fix Gradle Wrapper and re-import project ", nada acontece.

---

Top 5 Responder

1The Metal Beard @

Há uma diferença entre a versão Gradle e versão Gradle Plugin Android (0,12 . +). Parece que você precisa Gradle versão 1.10, não acho que mais tarde versões são supperted pelo plugin Gradle Android ainda. Enfim, acho que ter certeza que você usar Gradle versão 1.10 vai resolver esse problema .

2The End @

Se você quer mudar o gradle -wrapper para uma versão inferior você tem que mudar a distributionUrl

distributionUrl=http://services.gradle.org/distributions/gradle-1.10-all.zip

e execute novamente a tarefa wrapper. Se isso não é suficiente para suprimir apenas das pastas .gradle e gradle e os arquivos gradlew e gradlew.bat . O wrapper reprise e ele faz o download gralde 1.10

Desde gradle teve algumas grandes mudanças na API a partir da versão 1.10 e 1.12 não é possível construir qualquer projeto com uma versão superior, em seguida, os plugins são construídos com . Então, se o plug-in android é construir com gradle 1.10 você tem que usar a mesma versão