Falha [ INSTALL_FAILED_OLDER_SDK ] no Android Estúdio

? Ewen W. @ | Original: StackOverFlow
---

Então eu sei que muitas outras pessoas tiveram este problema, mas o meu é um pouco diferente. Tentei rodar o meu aplicativo em um G2 LG com Android 4.4.4, e uma nota 3 com Android 4.4.2, mas também não funcionou. Eu instalei a API 18, 19, 20 e SDKs .

Falha [ INSTALL_FAILED_OLDER_SDK ]

build.gradle:

 apply plugin: 'com.android.application'

android {
    compileSdkVersion 'android-L'
    buildToolsVersion "20.0.0"

    defaultConfig {
        applicationId "com.ween.control"
        minSdkVersion 8
        targetSdkVersion 'L'
        versionCode 1
        versionName "1.0"
    }
    buildTypes {
        release {
            runProguard false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    compile 'com.android.support:appcompat-v7:19.+'
}
---

Top 5 Responder

1msrowley @

Eu tinha exatamente o mesmo problema, isso resolveu minhas perguntas :

http://www.reddit.com/r/androiddev/comments/297xli/howto_use_the_v21_support_libs_on_older_versions/

Good luck!!

2fran @

Você não pode testar um aplicativo Android -L em um dispositivo com menor API. Dê uma olhada https://code.google.com/p/android-developer-preview/issues/detail?id=103&q=Type%3DDefect&colspec=ID%20Type%20Status%20Owner%20Summary .

3Steve G. @

Você precisa ter certeza de suas dependências são configurados como alvo a mesma SDK ( também certificar-se o SDK é suportado para a dependência ) .

A partir da versão 0,11, o plugin gradle agora utiliza a nova ferramenta de fusão manifesto por padrão que você pode usar para evitar conflito configurações ao mesclar manifestos de suas dependências, enquanto a construção, especificando <uses-sdk tools:node="replace" /> no seu arquivo AndroidManifest.xml .

http://tools.android.com/tech-docs/new-build-system/user-guide/manifest-merger

crédito vai para http://stackoverflow.com/questions/24457831/failure-install-failed-older-sdk-android-l