Este SDK Android requer Android Developer Toolkit versão 23.0.0 ou superior

? Kalpesh @ | Original: StackOverFlow
---

Eu recebo o seguinte erro quando eu começar o meu Eclipse.

Este SDK Android requer Android Developer Toolkit versão 23.0.0 ou superior

E quando eu tento atualizar a partir de Help> Install New Software ... usando o link de atualização eclipse https://dl-ssl.google.com/eclipse/plugin/4.2

Isso me dá seguinte erro:

Cannot complete the install because of a conflicting dependency.
Software being installed: Android Development Tools 23.0.1.1256982 (com.android.ide.eclipse.adt.feature.feature.group 23.0.1.1256982)
Software currently installed: Android Development Tools 22.6.3.v201404151837-1123206 (com.android.ide.eclipse.adt.feature.group 22.6.3.v201404151837-1123206)
Only one of the following can be installed at once: 
ADT XML Overlay 23.0.1.1256982 (overlay.com.android.ide.eclipse.adt.overlay 23.0.1.1256982)
ADT XML Overlay 22.6.3.v201404151837-1123206 (overlay.com.android.ide.eclipse.adt.overlay 22.6.3.v201404151837-1123206)
Cannot satisfy dependency:
From: Android Development Tools 23.0.1.1256982 (com.android.ide.eclipse.adt.feature.feature.group 23.0.1.1256982)
To: overlay.com.android.ide.eclipse.adt.overlay [23.0.1.1256982]
Cannot satisfy dependency:
From: Android Development Tools 22.6.3.v201404151837-1123206 (com.android.ide.eclipse.adt.feature.group 22.6.3.v201404151837-1123206)
To: overlay.com.android.ide.eclipse.adt.overlay [22.6.3.v201404151837-1123206]

O que devo fazer agora?

---

Top 5 Responder

1Dhawal Sodha Parmar @

Não há necessidade de fazer alguma coisa,

basta baixar novo eclipse, instalar ADT 23.0.0 do link abaixo

https://dl-ssl.google.com/android/eclipse/

resolver o seu problema ...

sua aconteceu porque você tem SDK 23.0.1 e 23.0.1 ADT atualização não está disponível ....

yesterday i have same issue, i have solved that.. 2user285oo6 @

Como você tem feito a atualização para o SDK 23,0 sem atualizar o ADT ele irá mostrar o erro tipo como você mencionou na captura de tela .

Basta atualizar o SDK para 23,0 é inútil e até menos que você também atualizar a ferramenta de desenvolvimento relacionados em ADT.

Siga os passos

First delete the SDK 23.0 and update the ADT to 23.0 For doing the update you need to click on Install new software from help and choose the ADT/ https://dl-ssl.google.com/android/eclipse/ under the link upon which you get the new Development tools to update click all >next to continue . Upon successful completion you can now update the SDK to 23.0.

Nota: - Muitos dos que tentaram atualizar o SDK ter enfrentam um problema Não é possível concluir a instalação por causa da dependência conflito  Este SDK Android requer Android Developer Toolkit versão 23.0.0 ou superior

Assim, o seu melhor para se ater apenas ao 22.6v da ADT. A actualização para 23,0 está cheia de erros e vai demorar algum tempo para corrigir os erros

3Kikiwa @

Se você tem um conflito com a versão anterior :

Select Help > Install New Software Click on already installed Select all Android software on version 22.* Click on Uninstall Work with: https://dl-ssl.google.com/android/eclipse/ Select Developer Tools and Next Next, Accept the license agreement and Finish.

EDIT: Este truque é, provavelmente, não mais necessário!

Tente atualizar suas ferramentas do SDK para 23.0.2+ e construir & amp; ferramentas da plataforma de Ap 20 antes.

4Kalpesh @

A melhor solução para isso é baixar um novo ADT de http://developer.android.com/sdk/index.html

5Joff @

Kalpesh Não exclua SDK 23.0 ele irá remover a pasta de " ferramentas " e você não será capaz de executar o Gerenciador SDK depois disso. Eu sei porque eu acabei de fazer isso. Bad sugestão!

A solução de Kikiwa funcionou para mim.