Usando 1.7 requer a compilação com Android 4.4 ( KitKat ); Atualmente usando API 14

? user3810543 @ | Original: StackOverFlow
---

Então, eu recentemente trocou o alvo do meu projeto para android 4.0. Agora eu tenho praticamente erros em cada linha e o erro " Usando 1.7 requer a compilação com Android 4.4 ( KitKat ); atualmente usando API 14" no console. Então, minha pergunta é: como faço para mudar isso para trabalhar com api 14 e compilar ? obrigado.

---

Top 5 Responder

1Eran @

No eclipse : Botão direito do mouse seu projeto -> propriedades -> a partir da barra lateral, escolha "Java Compiler " e, em seguida, alterar o nível de cumprimento Compiler para 1,6

2Justin @

Não concordo com Eran, esta causa de erro, definindo Project build target para 4.0 (API 14). Se a mudança para Java 1.6, você não pode usar Java estilo 1,7 sode, por ex : ArrayList myArrayList = new ArrayList<>(); .  Para corrigir isso, definir o seu alvo para 4,4 (API 19) ou superior.