Tentando atualizar ADT - recebendo erro " dependência conflitantes "

? uj- @ | Original: StackOverFlow
---

Eu tive uma série de problemas desde que eu tentei importar um projeto android .

A localização do meu SDK não foi configurado nas preferências (mesmo que tinha sido antes e ADT estava funcionando perfeitamente bem ) . Quando eu tentar definir o caminho para a pasta SDK, ele diz

Este SDK Android requer Android Developer Toolkit versão 23.0.0 ou superior. A versão atual é 22.6.2.v201403212031-1085508 . Por favor, atualize ADT para a versão mais recente .   Então eu tento atualizar Eclipse pelo seguinte como sugerido em outro post SO ( uma vez que " Check for updates" continua me dizendo que não há atualizações disponíveis:

Ajuda -> Instale o novo software -> p2repo - https://dl-ssl.google.com/android/eclipse/ - > Verificar ferramentas do desenvolvedor - > Próximo          E é aí que eu recebo o seguinte erro:

Cannot complete the install because of a conflicting dependency.
Software being installed: Android Native Development Tools 23.0.2.1259578 (com.android.ide.eclipse.ndk.feature.feature.group 23.0.2.1259578)
Software currently installed: Android Developer Tools 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.adt.package.product 22.6.2.v201403212031-1085508)
Only one of the following can be installed at once: 
ADT CDT Integration 23.0.2.1259578 (com.android.ide.eclipse.ndk 23.0.2.1259578)
ADT CDT Integration 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.ndk 22.6.2.v201403212031-1085508)
Cannot satisfy dependency:
From: ADT Package 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.adt.package.feature.group 22.6.2.v201403212031-1085508)
To: com.android.ide.eclipse.ndk.feature.group 22.6.2

Cannot satisfy dependency:
From: Android Developer Tools 22.6.2.v201403212031-1085508 (com.android.ide.eclipse.adt.package.product 22.6.2.v201403212031-1085508)
To: com.android.ide.eclipse.adt.package.feature.group [22.6.2.v201403212031-1085508]

Cannot satisfy dependency: 
From: Android Native Development Tools 23.0.2.1259578 (com.android.ide.eclipse.ndk.feature.feature.group 23.0.2.1259578)
To: com.android.ide.eclipse.ndk [23.0.2.1259578]

Cannot satisfy dependency:
From: Android Native Development Tools 22.6.2.v201403212031-1085508  (com.android.ide.eclipse.ndk.feature.group 22.6.2.v201403212031-1085508)
To: com.android.ide.eclipse.ndk [22.6.2.v201403212031-1085508]

Como posso obter êxito em torno desses erros e atualizar eclipse ?

---

Top 5 Responder

1The_ehT @

Basta desinstalar a versão atual é ADT 22.6.2.v201403212031-1085508 indo para Ajuda> Detalhes da instalação > software instalado e, em seguida, selecione ADT ( versão antiga ) > clique em Desinstalar. Agora reinstale mais recente ADT. Dessa forma, eu era capaz de atualizar ADT a versão atual, espero que ajude . Nota: Isso não vai funcionar em adt -bundle .

2Lightshadow @

Hoje, eu tenho o mesmo erro que você:

Este SDK Android requer Android Developer Toolkit versão 23.0.0 ou superior. A versão atual é 22.6.2.v201403212031-1085508 . Por favor, atualize ADT para a versão mais recente .

YOUR MESSAGE:

Este SDK Android requer Android Developer Toolkit versão 23.0.0 ou superior. A versão atual é 22.6.2.v201403212031-1085508 . Por favor, atualize ADT para a versão mais recente .

I fixado em 5 minutos :

1- Certifique-se de que você ainda tem o arquivo zip ( me que é " ADT- bundle- windows- x86_64-20140321 " )

2 - Copie o conteúdo do zip onde você quer que ele seja

3- É como 1,30 GB (eu acho), então dependendo do seu computador que pode demorar alguns minutos

4 Uma vez que é copiado, abri-lo.

5 -Go na pasta eclipse, em seguida, abra o aplicativo eclipse ( você pode até fixá-lo para a barra de tarefas, se você usá-lo muito )

Eu tive esse problema, algumas vezes, e isso sempre funciona para mim.

3Lightshadow @

Para Sanjay Manohar :

Basicamente, quando você baixou eclipse, foi em um arquivo zip. Você necessário para extrair os arquivos para usar seu conteúdo. O arquivo que eu baixei foi batizada de " adt -bundle- windows- x86_64-20140321 " e eu tenho que partir " https://developer.android.com/training/basics/firstapp/index.html " .

Se você estiver usando eclipse, você provavelmente tem o arquivo zip em seus downloads, por isso não há necessidade de baixá-lo novamente .

Se eu fosse você, eu faria um arquivo chamado " ANDROID " e nele colocar o arquivo zip (para usar como um backup futuro, se você tem problemas semelhantes )

Também gostaria de criar uma pasta da área de trabalho nomeado para todos os meus projetos, e uma pasta chamada ADT em que eu iria extrair o conteúdo do arquivo zip.

Esta seria a pastas dentro " ANDROID " :

-ADT (-> Contém os arquivos extraídos do arquivo zip " adt -bundle- windows- x86_64-20140321 " )

-workspace (-> contém meus projetos )

- -adt -bundle windows- x86_64-20140321 (-> o arquivo zip)

Desculpe para a criação de uma nova resposta, eu não tenho a reputação ...

4priya @

Desinstalar todos os componentes conflitantes. No meu caso, Open -GL, DDMS, ADT etc estavam em conflito com a atualização. Então eu desinstalado todos estes, usando ..

Ajuda-> Sobre o Eclipse SDK- > Instalação details- > selecione o componente para uninstall- > desinstalação

Em seguida, atualize o seu ADT.

Ajuda-> Instale New software- > Selecionar site de atualização do Adt ( https://dl-ssl.google.com/android/eclipse/ se não apresentar adicioná-lo ) em sítios disponíveis w / s . E atualizar o ADT.

5Ankit Sachan @

Basta selecionar ADT a partir de ferramentas de desenvolvedor suspensa