Android gradle compilação de erro: (9, 0 ) Método DSL Gradle não encontrado: ' compilar ()' .

? BigBoy1337 @ | Original: StackOverFlow
---

Estou recebendo o seguinte erro de compilação quando tento sincronizar o meu projeto:

Error:(9, 0) Gradle DSL method not found: 'compile()'
Possible causes:The project 'AlexTest' may be using a version of Gradle that does not contain the method.
The build file may be missing a Gradle plugin.
link: Apply Gradle plugin

Eu tentei aplicar a cada plug-in gradle eles me ligar nesse link na parte inferior, mas mesmo problema, então eu concluir que o primeiro erro é a causa.

Aqui está o arquivo build.gradle para AlexTest ( o diretório do projeto ):

buildscript {
    repositories {
        jcenter()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:0.13.2'
        compile 'com.google.android.gms:play-services:6.1.11'
        // NOTE: Do not place your application dependencies here; they belong
        // in the individual module build.gradle files
    }
}

allprojects {
    repositories {
        jcenter()
    }
}

Acho que foi o arquivo gradle ele estava tendo problemas com . Mas eu não tenho certeza de qual método ele está se referindo.

Também aqui é os gradle-wrapper.properties que ele também se refere a:

#Mon Nov 10 01:06:12 PST 2014
distributionBase=GRADLE_USER_HOME
distributionPath=wrapper/dists
zipStoreBase=GRADLE_USER_HOME
zipStorePath=wrapper/dists
distributionUrl=https://services.gradle.org/distributions/gradle-2.1-all.zip

talvez a versão gradle no distributionUrl precisa corresponder a um na dependência?

Eu também tenho um arquivo build.gradle na pasta do próprio app - um nível mais baixo, embora eu não acho que é o que ele estava se referindo, mas aqui está:

apply plugin: 'com.android.application'

android {
    compileSdkVersion 20
    buildToolsVersion "21.1.1"

    defaultConfig {
        applicationId "com.snappiesticker.alextest"
        minSdkVersion 16
        targetSdkVersion 20
        versionCode 1
        versionName "1.0"
    }
    buildTypes {
        release {
            runProguard false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    compile 'com.google.android.gms:play-services:6.1.+'
}
---

Top 5 Responder

1CommonsWare @

Eu tentei aplicar a cada plug-in gradle eles me ligar nesse link na parte inferior, mas mesmo problema, então eu concluir que o primeiro erro é a causa.

Correct.

Aqui está o arquivo build.gradle para AlexTest ( o diretório do projeto ):

Você vai notar que este arquivo contém um comentário de código :

    // NOTE: Do not place your application dependencies here; they belong
    // in the individual module build.gradle files

Você não seguir essas instruções .

Remova a linha compile 'com.google.android.gms:play-services:6.1.11' a partir desse arquivo . Deixe o compile 'com.google.android.gms:play-services:6.1.+' que você tem no outro arquivo build.gradle .

O dependencies fechamento em buildscript é para Gradle plugins apenas . O alto nível dependencies encerramento, encontrado no arquivo build.gradle do módulo, é para dependências de aplicativos .