Analisando os dados para Android L failed.Unsupported major.minor versão 51.0

? sasu @ | Original: StackOverFlow
---

Depois de instalar o ADT Plugin para Eclipse, eu tentei fazer um novo app Olá, mundo Android .

Mas encontrei-me com o seguinte erro quando tentei abrir um novo aplicativo Android . Eu estou trabalhando com JDK 7.0 e JRE 7.0. I inicialmente trabalhou com JDK 6.0, mas encontrou-se com o mesmo erro, daí eu desinstalei e instalei o JDK 7.0 e mudou as configurações de caminho, respectivamente.

O erro é claramente :

Carregamento de dados para Android L ( Preview) encontrou um problema . Analisando os dados para Android L failed.Unsupported major.minor versão   51.0 .

Meus níveis de conformidade também são alteradas para JDK apenas 1,7 . E eu também mudei de cumprimento JRE para 1,7 .

---

Top 5 Responder

1Sree14 @

Por favor, verifique o seguinte.

Ensure that you have restarted your system after specifying the path name. You can look for the following icon on your eclipse's layout screen. !( http://i.stack.imgur.com/WoX58.png ) The "20" specifies the android version to use when rendering layouts. Change it and see. Last but not least review your ADT configurations. Hope this helps. 2AJP @

Você pode "resolver" isso desinstalando o L SDK Android usando o Gerenciador de SDK Android .

Não satisfatório .

Edit

Acho http://stackoverflow.com/a/24566948/539490 é efetivamente o que sugere a mesma coisa, mas sem a desinstalação ( ao invés de apenas selecionando a versão da API do que realmente funciona ) .

3Ligen Yao @

Verifique a sua versão JDK . Deve ser JDK1.7 . O JDK 1.6 não funciona.

4tounaobun @

Basta apagar as plataformas Android L . Redirecionar para o diretório do SDK do Android .

adt -bundle- mac- x86_64-20140321 / SDK / plataformas / android -L

excluir diretório android -L e reinicie o eclipse.

5Haimanti @

Às vezes pode ser apenas porque o nível de conformidade do compilador não está definido corretamente em ambientes Eclipse Java Compiler .

Ir para o Eclipse Preferências, em Java secção- > ir para Compiler e, em seguida, em nível de conformidade JDK 1.7 selecione