Instalação BlueStacks falhou mais velho erro sdk

? Raul Puri @ | Original: StackOverFlow
---

Oi a todos que eu estou tentando instalar um apk que eu projetei com versão minsdk de 14 e alvo de 19 para BlueStacks e sua falha . O que é estranho é que eu instalei um aplicativo com a mesma versão api de 14/19 nesta mesma BlueStacks jogador há um mês ( eu apaguei -lo agora, embora a trocá-lo com o novo apk ) . Por favor, deixe-me saber o que api eu deveria estar desenvolvendo por BlueStacks . Aqui está o meu xml

<?xml version="1.0" encoding="utf-8"?>
<manifest xmlns:android="http://schemas.android.com/apk/res/android"
package="com.example.demoww"
android:versionCode="1"
android:versionName="1.0" >

<uses-sdk
    android:minSdkVersion="14"
    android:targetSdkVersion="14" />

<application
    android:allowBackup="true"
    android:icon="@drawable/earth"
    android:theme="@style/AppTheme" >
    <activity
        android:name=".LoadScreen"
        android:label="@string/Linking_players" >
        <intent-filter>
            <action android:name="android.intent.action.MAIN" />

            <category android:name="android.intent.category.LAUNCHER" />
        </intent-filter>
    </activity>
    <activity
        android:name=".SignUp"
        android:label="@string/Signup" >
    </activity>
    <activity android:name=".MainActivity" >
        <meta-data
            android:name="android.support.UI_OPTIONS"
            android:value="splitActionBarWhenNarrow" />
    </activity>
    <activity android:name=".suggestedfriends" >
        <meta-data
            android:name="android.support.UI_OPTIONS"
            android:value="splitActionBarWhenNarrow" />
    </activity>
    <activity android:name=".search" >
        <meta-data
            android:name="android.support.UI_OPTIONS"
            android:value="splitActionBarWhenNarrow" />
    </activity>
    <activity android:name=".requests" >
        <meta-data
            android:name="android.support.UI_OPTIONS"
            android:value="splitActionBarWhenNarrow" />
    </activity>
    <activity android:name=".raul_profile" >
        <meta-data
            android:name="android.support.UI_OPTIONS"
            android:value="splitActionBarWhenNarrow" />
    </activity>
    <activity android:name=".raul_message" >
        <meta-data
            android:name="android.support.UI_OPTIONS"
            android:value="splitActionBarWhenNarrow" />
    </activity>
    <activity android:name=".profile" >
        <meta-data
            android:name="android.support.UI_OPTIONS"
            android:value="splitActionBarWhenNarrow" />
    </activity>
    <activity android:name=".messages" >
        <meta-data
            android:name="android.support.UI_OPTIONS"
            android:value="splitActionBarWhenNarrow" />
    </activity>
    <activity android:name=".friendslist" >
        <meta-data
            android:name="android.support.UI_OPTIONS"
            android:value="splitActionBarWhenNarrow" />
    </activity>

</application>
<!-- To access Google+ APIs: -->
<uses-permission android:name="android.permission.INTERNET" />

<!--
 To retrieve OAuth 2.0 tokens or invalidate tokens to disconnect a user. This disconnect
 option is required to comply with the Google+ Sign-In developer policies







-->
<uses-permission android:name="android.permission.USE_CREDENTIALS" />

<!-- To retrieve the account name (email) as part of sign-in: -->
<uses-permission android:name="android.permission.GET_ACCOUNTS" />

<!-- To auto-complete the email text field in the login form with the user's emails -->
<uses-permission android:name="android.permission.READ_PROFILE" />
<uses-permission android:name="android.permission.READ_CONTACTS" />

</manifest>
---

Top 5 Responder

1Janin zah @

Você pode verificar qual versão do Android a sua versão do BlueStacks é projetado para, olhando para a tabela abaixo :

http://forum.xda-developers.com/wiki/BlueStacks_App_Player

A versão Android do meu BlueStacks é 4.0.4 . O nível de API é 15.

De acordo com a tabela, a última versão (beta) está de acordo com 4.4.2 ( KitKat ) .

A menos que, você tem essa versão, você tem que baixar o nível API para o seu apk para 15 ou mesmo inferior.

Se os seus BlueStacks é instalado em um PC, você pode verificar sua versão por:

Iniciar> digite "regedit"

No editor de registro, vá em " HKEY_LOCAL_MACHINE", "SOFTWARE ", " BlueStacks " e ele deve estar lá em " Version" .

[ Estas instruções para encontrar o número de versão de um BlueStacks instalados foram originalmente postados por intheGame . ]

2Steph @

Se os seus BlueStacks é instalado em um PC com Windows, você pode verificar sua versão passando o mouse sobre seu ícone da barra de tarefas .

Instalação BlueStacks falhou mais velho erro sdk