Depois de atualização - acidente com.google.android.gms : play- serviços: 5.2.8

? user3871754 @ | Original: StackOverFlow
---

minhas dependências :

compile "com.android.support:appcompat-v7:20.+"
compile 'com.google.android.gms:play-services:5.2.08'
compile 'com.android.support:support-v4:21.0.+'

mas ainda : Google Play serviços fora da data . Requer 5208000 mas encontrou 5089036

como isso é possível ?

Atualizar este trabalho:

compile 'com.google.android.gms:play-services:5.0.89'

or

compile 'com.google.android.gms:play-services:6.1.11'

or

compile 'com.google.android.gms:play-services:6.+'

---

Top 5 Responder

1Michele @

Você precisa atualizar o Google Play Services da loja jogar em seu dispositivo, se você não vê qualquer atualização de espera até que sai

https://play.google.com/store/apps/details?id=com.google.android.gms

Em alternativa pesquisar no Google e instalado o novo apk ou usar uma versão mais antiga, como 5.0.77 ou 5.0.89

2Jerome Campbell @

Alterar o Google Play versão do Service em sua build.gradle para a versão do seu dispositivo ou emulador .

compile 'com.google.android.gms:play-services:5.0.89' 
3josacky @

A versão que você está procurando é 5.2.08 .

Android Studio irá oferecer automaticamente para atualizá-lo para a nova versão. No entanto, devido a um erro, ele deixa cair a zero à esquerda em "08", o que significa que ele substitui a dependência com " 5.2.8 " em vez de " 5.2.08 ", que não funciona. Para corrigir isso, editar a dependência de ler " 5.2.08 " em vez de " 5.2.8 "

This will work:

compile 'com.google.android.gms:play-services:5.2.08'

fonte: http://tools.android.com/knownissues

4jQwierdy @

Para as pessoas que sofrem deste problema, mas não são capazes de fazer o outro trabalho - o meu problema era que eu instalei o Google Play 5.2.08 no meu arquivo gradle ( compilar ' com.google.android.gms : play- serviços : 5.2.08 ' ), porque 5.0.77 não estava funcionando.

Carreguei o app em meu telefone e não deu certo ,

Eu tive a atualização mais recente ( que eu poderia começar no meu telefone - 4.4.2 Android ) do google jogar tão me dizendo para atualizar não me deu nenhuma opção

I terminou apenas a necessidade de atualizar o meu arquivo gradle para a última googlePlay compatível, no meu caso, a versão 5.0.89 . Então descubra o que versão

5friederbluemle @

You can now use

compile 'com.google.android.gms:play-services:6.1.11'